1
vote
1answer
45 views

Is there TRIM support in OS X 10.6.9 for PowerPC?

A friend of mine has a PowerBook running 10.6.9. To give it another lease of life, he'd like to install an SSD. Question is: does OS X on PPC have TRIM support?
0
votes
2answers
45 views

Java 7 on PowerPc

I have several powermac G4 computers running leopard, and would like to use them as a test environment for my Java 7 based applications. I have looked online a bit but could not find any way to ...
0
votes
1answer
189 views

How can I upgrade my OS X 10.4.11 to Snow Leopard and then Mavericks?

I am on iMac PowerPC with OS X 10.4.11 Can I upgrade to Snow Leopard and then to Mavericks? If so, how?
1
vote
0answers
74 views

Why my iBook G4 superdrive spits out the Mac OS X Leopard Install Disk?

The SuperDrive of my late 2005 iBook G4 died, so I installed a new one. But now the new drive does not mount the Leopard Install Disk. But it mounts any other DVDs/CDs (music, movies). The disk mounts ...
2
votes
3answers
1k views

Powerpc apps on a MacBook Pro with OS X 10.9

I have several Power PC apps that will no longer work with OS X 10.9. How can I remove them from my MAC?
0
votes
0answers
211 views

PPC emulator to run MacOSX 10.5

Is there any PPC emulator (for either Intel Macs or any Linux) which can run MacOSX 10.5 PPC? My current research only points me to PearPC and the latest post/release was from 2011. On the homepage, ...
1
vote
1answer
887 views

Installing OSX onto PPC using Intel Mac and Firewire

I'm fighting a losing battle and I'm hoping you can help. I have an old G5 PPC machine with no OSX installed. I have the installation disk. Unfortunatley there seesm to be an issue with the G5 ...
0
votes
1answer
97 views

Black screen after failed restore - G5

I tried to restore a G5, something went wrong and now I have this at startup: dyld: library not loaded: /usr/liblibconv.2.dylib Referenced from /bin/sh Reason: Incompatible library version: sh ...
0
votes
0answers
103 views

Web development on PowerPC

I'm interested in LAMP stack and Nodejs stack for PowerPC (iMac g5). Do they exist for Mac OS X 10.5.6 PPC?
6
votes
5answers
9k views

Can we upgrade PowerPC Macs to OS X 10.7 now that 10.8 is out?

I know that 10.8 is out now, but we have older Macs that will not work under 10.8, as they do not have Intel processors. Can we still buy and get 10.7, which I believe will support older CPUs?
1
vote
1answer
1k views

List of PowerPC apps

I'm breathing life again into an "old" MacMini G4 1.5Ghz. Instead of searching each and every one of my favorite apps to check whether there's still an old version that runs on PowerPC / OSX 10.5.8, I ...
1
vote
2answers
591 views

Why is my G5 running so slow and hot?

We have an early 2005 Power Macintosh G5 2.0 DP (PCI). This tower has been having a lot of problems: freezing randomly, runs hot and slow, fans race intermittently, CDs/DVDs don't always load, won't ...
2
votes
3answers
10k views

Most suitable Mac OS X version for Power Mac G5?

I have a Power Mac G5 Dual 1.8 with 3.5GB of ram running 10.5.8 The system feels so slow though.. :( Taking in mind that this was a beast back then, which would be the best OS X version I could ...
1
vote
4answers
2k views

Where I can buy an original OS X Leopard PPC disc for my iMac G4?

I've a wonderful iMac G4 with 2 GB of RAM so I can install/upgrade from Panther to Leopard but I cannot officially buy from Apple site! Is there a possibility somewhere to buy an original disk?
3
votes
1answer
342 views

What software for video editing should a G5 Tower Use?

My friend has a G5 Tower and would like to create some music videos for his band. I've looked into Final Cut Pro, but unfortunately the latest version is Intel only. I assume if we went that route, ...
5
votes
3answers
7k views

Whats the last OS X that supported Power PC?

I still have an old Power PC machine and was wondering what the latest OS X build I can install on it?