0
votes
1answer
72 views

Black screen after failed restore - G5

I tried to restore a G5, something went wrong and now I have this at startup: dyld: library not loaded: /usr/liblibconv.2.dylib Referenced from /bin/sh Reason: Incompatible library version: sh ...
1
vote
1answer
39 views

Replace power supply on late 2005 G5

I recently bought an old G5 to use as a server. Whilst there the guy had another G5 that I bought for spares. The 'spares' G5 is a newer model with better GPU / CPU etc so I intend on swapping them ...
2
votes
2answers
9k views

Most suitable Mac OS X version for Power Mac G5?

I have a Power Mac G5 Dual 1.8 with 3.5GB of ram running 10.5.8 The system feels so slow though.. :( Taking in mind that this was a beast back then, which would be the best OS X version I could ...