0
votes
0answers
24 views

Want to Update OpenSSL with Ruby 2.0.0 Already Installed

I have Ruby 2.0.0-p451 installed via RVM. From what I have read online the newer versions of openssl need Ruby 2 installed. I'm running RVM 1.25.25. I currently host Ruby on Rails websites on my Mac ...
7
votes
1answer
10k views

Ruby 2.0.0 install via RVM: errors surrounding openssl

Using: Mountain Lion 10.8.2, RVM 1.18.15 Having trouble with, apparently, openssl when trying to install Ruby 2.0.0 via RVM: $ rvm install 2.0.0 ... Extracting openssl to ...
1
vote
2answers
3k views

Ruby 2.0.0 fails to install because of openssl

I can't install ruby from source, on configuration (./configure) it states Ignore OpenSSL broken by Apple. Please use another openssl. (e.g. using `configure --with-openssl-dir=/path/to/openssl') ...
6
votes
2answers
2k views

where is Ruby looking for SSL_CERT_FILE?

I am trying to find out where Ruby expects to find its openssl CA list. My environment is: Mac OS 10.7.5 OpenSSL from homebrew Rbenv from homebrew Ruby 1.9.3, installed using rbenv and ...
3
votes
1answer
799 views

Ruby 1.9.3's infamous OS X OpenSSL segfault in http.rb:799

[Post shortened and updated with an answer.] Ruby 1.9.3 compiled on OS X 10.7.4 with MacPorts crashes in my Rails apps when using SSL in http.rb, e.g. when authenticating to Facebook: (facebook) ...