A package management system for OS X. It allows for easy installation of free/open source software. Formerly called DarwinPorts.

learn more… | top users | synonyms

0
votes
1answer
484 views

Move python modules from one installation to another

I have several versions of Python installed, some through MacPorts and some directly via the python.org installers. I have modules installed through MacPorts and via PyPI, for the same Python version ...
0
votes
0answers
346 views

License problems installing aquaterm via macports

I am trying to install aquaterm via macports. I run sudo port install aquaterm This gives back an error: ---> Building aquaterm Error: org.macports.build for port aquaterm returned: command ...
0
votes
0answers
1k views

Installation of Wine via MacPorts not working with 10.8 and XCode 4.4

I had installed wine on my computer with then 10.7.4. It worked perfectly. Then I updated to 10.8 and wine did not work, so I uninstalled wine and macports. It gave me an error that winetricks (I ...
0
votes
1answer
559 views

Unable to update MacPorts: “symbol(s) not found for architecture x86_64”

I'm trying to run sudo port selfupdate to but part of the build process seems to be generating errors. I've run it with -d, and here's the output: DEBUG: MacPorts sources location: ...
0
votes
1answer
104 views

Apache module run under MacPorts gives SQLite error

I have an Apache module, compiled from source, which works just fine with the stock Apache 2.2 on Mac OS X 10.5 through 10.7. However, under the Apache 2.2.22 installed by MacPorts, running ...
0
votes
1answer
234 views

MacPorts 2.0.3 uninstalling package gives error “this entry does not own the given file”

I'm hitting an error while trying to uninstall some packages in my MacPorts 2.0.3 installation, and I can't figure out what's causing them or how to resolve them. Googling around lead to nothing ...
0
votes
0answers
245 views

Trouble installing sqlite3 on OS X 10.5.8

I am trying to install Rails 3, but having trouble with sqlite3. First I tried $ sudo gem install sqlite3 however, I got this error message: http://pastie.org/2419493 After googling around, I ...