0
votes
1answer
106 views

MacPort - jslint fails to install due to incompatible spidermonkey installation

Problem Description in Brief: I am trying to install jslint which depends on the spidermonkey macport. Installation of spidermonkey is successful, however, it appears to be incompatible with the ...
1
vote
1answer
307 views

How to make ffmpeg use correct libfreetype version?

I have a PHP application that uses ffmpeg with libfreetype. I installed both ffmpeg and libfreetype from macports. But I keep getting this error: 2013-08-30 14:44:21 - Generate poster - Create ...
1
vote
0answers
113 views

PHP exec() with Mac ports issue

I'm running PHP 5.3 from Mac Ports. I'm seeing some odd behavior with "exec()" that I can't track down. Calling commands that are installed in system-standard directories work, but calling commands ...
2
votes
1answer
305 views

Apache problem with hostname on OSX 10.8.4

After updating to 10.8.4 I am having trouble running my macports apache server. I stop the built-in apache with: sudo apachectl stop, then I try to start macports apache with: sudo ...
1
vote
0answers
168 views

How to use a different mirror of macports rather than the offical mirrors?

How to use a different mirror rather than the mirrors in the list? Well, I mean not only download port.tar from other mirror, like the question here, but also download packages from a different ...
1
vote
0answers
45 views

Is there any way to speed up kdiff3 startup time?

I recently switched over to OS X from Kubuntu and am trying to get my favourite development tools working. In Kubuntu I always used kdiff3 as my git difftool. I can get it to work on OS X, either by ...
0
votes
0answers
115 views

Editing $PATH variable for apache on mountain lion

I've just installed ImageMagick using macports and am trying to use it from a php site running on Apache, but nothing I do works to add /opt/local/bin:/opt/local/sbin to my path. So far I've tried ...
1
vote
2answers
1k views

Xcode 4.4.1 version not recognized in Macports?

After upgrading to Mountain Lion, I noticed that I can't install ports via Macports. I get the following error: Error: The installed version of Xcode (3.2.6) is too old to use on the installed OS ...
1
vote
1answer
249 views

Mountain Lion Figlet through MacPorts error?

I've just installed Mountain Lion, Xcode 4.4.1 + command line tools, and MacPorts for ML. It's working for other packages but I can't get figlet to install. When I use sudo port install figlet in ...
3
votes
1answer
4k views

Macports issues after Mountain Lion upgrade

After upgrading Lion to Mountain Lion, the MacPorts system seems broken. Refering to the MacPorts's migration page, the best solution seems to unistall all and reinstall all the ports. Is there a ...
0
votes
0answers
1k views

Installation of Wine via MacPorts not working with 10.8 and XCode 4.4

I had installed wine on my computer with then 10.7.4. It worked perfectly. Then I updated to 10.8 and wine did not work, so I uninstalled wine and macports. It gave me an error that winetricks (I ...
6
votes
1answer
3k views

Mountain Lion Broke MacPorts - Cannot Update

I am trying to update MacPorts but get the following error. sudo port selfupdate Password: ---> Updating MacPorts base sources using rsync MacPorts base version 2.1.1 installed, MacPorts base ...