System for installing command-line Unix applications and tools on OS X. Free and open-source.

learn more… | top users | synonyms (1)

0
votes
1answer
18 views

Downgrade GCC version

How do I downgrade my GCC v5 to GCC version 4.7 ? I currently don't have Xcode installed and I am using the command line tool. More details : Apple LLVM version 7.3.0 (clang-703.0.29) Target: ...
0
votes
2answers
95 views

Is there a rhyming dictionary I can run on the OSX command line?

Is there a rhyming dictionary I can run on the OSX command line? I found these but don't know how to get them running on my Mac: https://trac.macports.org/ticket/39651 ...
1
vote
1answer
3k views

“ERR_CONNECTION_REFUSED” on localhost after (I think) upgrading Apache via homebrew

I maintain a local web development environment on my Mac via Homebrew, set up in roughly the way described here: ...
1
vote
0answers
17 views

Why “Too many open files” error is occurred while opening a webpage with polipo installed on OS X 10.11.4?

I have installed polipo-1.1.1 caching proxy on my OS X 10.11.4 with homebrew: brew install polipo --with-large-chunks Sometimes opening URLs (this page for example) is failed with this error ...
0
votes
1answer
16 views

How to Run Homebrew's Caskroom/cask/pdfinfo?

I run brew install Caskroom/cask/pdfinfo but I cannot find in my commandline. My PATH is /usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/Library/TeX/texbin How can you run pdfinfo of Homebrew?
0
votes
0answers
16 views

Build failed in step '(top-level)'

I'm trying to build the arm-unknown-linux-gnueabi cross-compiler toolkit on my mac. I've found a tutorial that seemed to be good (and it actually fixed a few of the problems I had had before. But then ...
1
vote
2answers
35 views

brew: how to delete outdated version of package

Homebrew upgrades itself to brew. And it looks like the maintainers have not implemented some daily-used commands like brew cleanup. So anyone knows how to delete outdated version of software ...
1
vote
1answer
44 views

Installing ffmpeg with homebrew?

I am trying to install ffmpeg and it's libraries with homebrew on a mac running osx (El Capitain). The installation completes however its seems only ffmpeg is installed and not ffprobe or drawtext. ...
3
votes
2answers
942 views

How to Install Octave in El Capitan?

The new GNU Octave 4.0.1 was released March 23, 2016. I would like to find some standard way to install it in El Capitan (mine OS X 10.11.3) because it has significantly better support in some ...
14
votes
6answers
5k views

Is there any way to upgrade brew cask

Is there any way to upgrade all brew casks? Something like brew cask upgrade?
0
votes
1answer
19 views

How to change the GNU Make's (default) default location of gcc

I run Mac OS X El Capitan 10.4. I have used brew to install Compilation Tools (https://www.topbug.net/blog/2013/04/14/install-and-use-gnu-command-line-tools-in-mac-os-x/). Now when I run make, it ...
7
votes
2answers
9k views

How to use Homebrew to install local archive

I'm trying to use Homebrew to install wget, but something is happening where the download is always corrupt. This happens for all packages, not just wget. I can download the tar.gz fine through a ...
13
votes
3answers
8k views

Make files in `/usr/local` writable for homebrew

I've been trying to get homebrew working nicely, but it appears everything inside /usr/local isn't writable, and everything falls over. It keeps telling me to recursively chown /usr/local, and I ...
17
votes
5answers
7k views

Upgrading brew in El Capitan

I just upgraded to El Capitan, and when I tried updating brew I got the following error: $ brew update Error: The /usr/local directory is not writable. Even if this directory was writable when you ...
1
vote
0answers
21 views

Brew installed Boost different versions

I am currently trying to work out how to handle different versions of libraries installed via Homebrew on OS X. In particular Boost. I did have boost installed (currently v159) and boost155, but ...
4
votes
1answer
307 views

Building mysql with readline instead of editline

I'd really like to be able to use readline instead of editline with the mysql client, but I can't find out how to do this. The bottled mysql that brew installs by default for mavericks is using ...
102
votes
4answers
52k views

What are pros and cons for MacPorts, Fink and Homebrew?

I'm just migrating from Ubuntu Linux to Mac, and everything is new and I'm re-learning a lot of stuff. On Linux I had the excellent apt-get to manage software packages. I googled for an alternative ...
0
votes
0answers
14 views

“config” scripts exist outside your system or Homebrew directories

I'm currently using pyenv and pyenv-virtualenv, which i've installed via Homebrew. I've added if which pyenv > /dev/null; then eval "$(pyenv init -)"; fi to enable shims and autocompletion and if ...
1
vote
1answer
1k views

Uninstall/ disable php 5.6.9 osx Yosemite

I´m running osx yosemite with homebrew, apache, php5.6.9 and have installed php 5.3. I need php 5.3 to run a certain api which known to have complications with ph5.6.9. But how can I disable php 5.6.9 ...
0
votes
1answer
106 views

Error while installing Homebrew on Mac OS X (10.10.3): Unable to change file mode on /usr/local/

When I run the command on the home brew website, /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)" I get: ==> This script will install: ...
0
votes
0answers
18 views

How to use SDL2 on OS X via Makefile? [migrated]

I have homebrew and its sdl2 package properly installed on OS X El Capitan, and the SDL2 headers are in /usr/local/include/SDL2, but when I use -lSDL2 in gcc and #include <SDL2/SDL.h> as in ...
0
votes
1answer
80 views

How to install specific version of python on OS X

I need to install python3.4 on my OS X. Tried to do it with brew install python3 and now I have python 3.5.1. But I need py3.4. How can I install python3.4 on my Mac?
1
vote
2answers
31 views

How to Install pdfimages in El Capitan?

I am reviewing the answer here about Extracting embedded images from a PDF. It is not in Homebrew. How can you install pdfimages in OS X El Capitan?
1
vote
1answer
19 views

Does Homebrew have a command-not-found hook?

Arch Linux's pkgfile has a command-not-found hook that you can source from your shell's startup file (.zshrc, .bashrc, or whatever). Does Homebrew have anything roughly equivalent to this?
1
vote
2answers
2k views

Trying to install Homebrew, but I get this “fatal: cannot create directory at 'Library/ENV/pkgconfig/10.10': Permission denied”

I am having issues with Brew. It was working fine, but now it's a little wonky. Tried re-installing, but I get this error:"fatal: cannot create directory at 'Library/ENV/pkgconfig/10.10': Permission ...
6
votes
2answers
10k views

Change compile configuration of package installation in brew

How can I change the compiler configuration when I use brew install? I want to compile vim with +farsi using brew. But it seems that +farsi is not available options in brew: $ brew install +farsi vim ...
6
votes
1answer
99 views

What is the best way to install Node js on OS X?

I currently have installed node and npm with the installer provided from their website. Although I have homebrew installed as well and running 'brew doctor' seems to complaint about some files ...
5
votes
1answer
2k views

How to remove outdated casks from Homebrew?

I am using homebrew-cask to keep my ecosystem of applications up-to-date. It is great when maintaining several computers at home, travel or on the go. However, when some packages are getting updated ...
3
votes
1answer
33 views

Using postgres with launchd without constant issues

I have postgres and passenger installed from homebrew, and use the os x built in apache. I have several rails apps that use postgres which are managed by passenger which in turn is managed by apache. ...
0
votes
2answers
48 views

wget gives error “dyld: Library not loaded: /opt/local/lib/libnettle.4.dylib”

When I try to use wget, I am getting this error message: $: wget dyld: Library not loaded: /opt/local/lib/libnettle.4.dylib Referenced from: /opt/local/bin/wget Reason: image not found Trace/BPT ...
121
votes
3answers
65k views

List of all packages installed using Homebrew

Is it possible to and how do I get a list of all the packages installed on my Mac using Homebrew? I am not interested in packages installed outside of Homebrew.
1
vote
1answer
50 views

Issue installing BasicTeX with Cask under OS X

I followed the instructions (that I could understand) to install BasicTeX from Cask and this was the output I got: basictex staged at '/opt/homebrew-cask/Caskroom/basictex/latest' (107M) I see ...
18
votes
2answers
9k views

Homebrew doctor warning: you have unlinked kegs in your Cellar

How do you fix this? $ brew doctor ... Warning: You have unlinked kegs in your Cellar Leaving kegs unlinked can lead to build-trouble and cause brews that depend on those kegs to fail to run properly ...
0
votes
0answers
25 views

`brew install qtkeychain` fails with some weird error

For compiling some software I need qtkeychain to be installed with brew, so I ran brew install qtkeychain which results in the following: $ brew install qtkeychain ==> Installing qtkeychain ...
1
vote
1answer
38 views

Mac Mini 1,1 (10.6.8) Missing libc++

My Mac Mini 1,1 running Snow Leopard 10.6.8 is missing libc++. Is there a version for OS X 10.6.8? Is there a way to install it again through Homebrew?
18
votes
4answers
21k views

Installing Xcode via command line

I am a Linux user and have never used OSX before. Someone asked me for help with installing some software on an OSX "Lion" server. I asked him to give me an SSH shell, assuming that would be ...
0
votes
0answers
17 views

how to 'custom install' with brew?

so I have to edit the install of wine, and apply a custom patch. The patch I want is here... https://bugs.winehq.org/attachment.cgi?id=38156 and when I add these lines with brew edit wine patch do ...
2
votes
1answer
340 views

What are the hardware requirements for Hypervisor.framework?

I was planning to use xhyve to virtualise FreeBSD on my early 2009 Mac Pro (eight core) which has a fresh install of El Capitan (with all updates).I installed via homebrew and I get the following ...
0
votes
1answer
24 views

Brew doctor complains about 2 unbrewed dylibs (possibly remnants from Samsung Sidesync)

I've just found that brew doctor gives me the following error : Please note that these warnings are just used to help the Homebrew maintainers with debugging if you file an issue. If everything you ...
5
votes
3answers
586 views

Is there a command like namei for OS X?

I'm sifting through some incorrect permission issues and discovered the namei command for Linux. Homebrew doesn't currently have a Mac port. namei - follow a pathname until a terminal point is ...
0
votes
1answer
37 views

Error when trying to install Homebrew?

I have a MacBook Air 11 (mid 2013), with OS X 10.8.5, and I want to install Homebrew, so I go to the site and copy and paste the following code in my terminal: /usr/bin/ruby -e "$(curl -fsSL ...
3
votes
3answers
1k views

I'm Getting Errors When I Try to do 'brew update'

I want to install a gem. The instructions strongly suggest that I use Homebrew to install the gem dependencies. I have not used Homebrew a lot, maybe once years ago. I do remember that El Capitan ...
14
votes
1answer
3k views

Does Spotlight normally index links in ~/Applications?

I have installed MacVim through homebrew, and this resulted in an alias in ~/Applications that points to /usr/local/Cellar/macvim/7.3-66/MacVim.app. Unfortunately MacVim does not show up in Spotlight ...
9
votes
4answers
2k views

Can't install inkscape on Yosemite with homebrew

It seems like I should be able to install inkscape with something like brew install inkscape based on what I've seen online. Unfortunately, when I try this I get Error: No available formula for ...
2
votes
1answer
34 views

Vim 7.4 hybrid line numbers not working (installed via Homebrew)

I recently discovered that Vim 7.4 enables a hybrid number mode, such that if you do set nu and set rnu, you'll see the absolute line number of the current line and relative line numbers everywhere ...
7
votes
2answers
145 views

Difference between installing an application on OS X and Windows

I've been using Windows for many years so far but just started using a MacBook with OS X. As far as I'm concerned when I install applications on Windows they just go into Program files (by default). ...
1
vote
1answer
92 views

Trouble running MySQL on OS X 10.9.5

So I ran over a lot of post treating of this specific problem but none of the answer seems to work for my case. So this is the process : I installed mysql via homebrew that lead me to this : ...
0
votes
1answer
231 views

MySQL fails to start after update

I am on Yosemite 10.10.5 and just now I updated my outdated MySQL to the latest version. I made a copy of my existing databases /usr/local/mysql/data/ somewhere safe. I have tried to setup MySQL both ...
0
votes
0answers
29 views

Fresh OS X install, cleanly manage terminal applications going forward

I just got a new Hard Drive and installed a fresh copy of El Capitan on it. I'm a computer programmer and use a ton of terminal commands. Is there anything I can / should do now that my computer has a ...
5
votes
2answers
2k views

Installed openvpn with brew but it doesn't appear to be installed correctly

I installed openvpn with brew. The installation went fine, no errors or missing dependencies. But now when I try to run it: users-MBP:~ user$ brew install openvpn Warning: openvpn-2.3.7 already ...