Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Short story: partition resizing using Disk Utility fails because MediaKit reports no such partition when I try to shrink it. I also tried the same while booting from the DVD, same result.

Details:

  • reFIT is installed and partition tables are in sync.

Current configuration:

  • refit
  • hfs+ - with OS X 10.6 on it
  • linux swap
  • linux ext4 - with Ubuntu on it

I can boot both, OS X and Ubuntu, via rEFIt boot menu but I want to shrink the OSX partition in order to add another NTFS partion where I want to install Windows 7 x64.

What should I do? enter image description here

share|improve this question

2 Answers 2

up vote 6 down vote accepted

Here is my current solution:

  • boot from OS X DVD - mandatory!
  • open terminal
  • diskutil list
  • umount "/Volumes/Macintosh HD"
  • fsck -f /dev/disk0s2
  • diskutil resizevolume /dev/disk0s2 100G
share|improve this answer

Easy method: iPartition ($45)

It gives you the option in the program to create a bootable DVD if you want to make changes to your boot drive. You could also run it from another Mac with the Mac you want to modify booted into Target Disk Mode.

Definitely not free, but it will save you a headache.

iPartition

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.