Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an older MacBook - not the aluminium unibody, the white one. Bought in the US.

All of a sudden it has stopped accepting the charge. Once I plugin the MagSafe connector it goes to green immediately doesn't charge up the battery.

If I remove the MagSafe connector, it powers down the laptop.

I have tried resetting the SMC - per the instructions on Apple's support site. That doesn't work. Perhaps I am doing it wrong? Doubt it though.

I tried putting the battery in the freezer for 14 hours, that doesn't work. This computer was not in storage, it had been in frequent use before the battery just decided to die.

If the battery needed replacement, wouldn't putting it in the freezer for a few hours at least give me back some juice?

I have OS X Lion installed on the machine.

When I go to the 'Power' section of my System Report, it says that the Battery should be replaced now under Condition. The cycle count is 487 - based on my readings, this sounds low (no??).

Thoughts?

More info from the System Report on the Battery:

Charge Information:
    Charge Remaining (mAh):     0
    Fully Charged:              No
    Charging:                   No
    Full Charge CApacity (mAh): 3416

Battery Installed:   Yes
Amperage (mA):       0
Voltage (mV):        9448
share|improve this question
    
How old is the battery? Battery have aging effect if they just sit around. –  Buscar 웃 Aug 18 '13 at 9:08
    
Did you try cleaning the pins/connectors on the magsafe and the battery? –  Buscar 웃 Aug 18 '13 at 9:38
    
There is more information in system report on battery, please report it, like mAh, Voltage ect... –  Buscar 웃 Aug 18 '13 at 9:51
    
@Buscar웃 The battery is as old as the laptop - which is to say a few years. It hasn't been just sitting around, the computer & battery are used actively and were working fine before it just stopped working. I did try cleaning the pins/connectors on the magsafe - but not the battery. Just regular alcohol will work, right? I am going to get more info from the system report on the battery and post it soon. –  marcamillion Aug 18 '13 at 19:30
    
@Buscar웃 I updated the question with that info you asked for. –  marcamillion Aug 18 '13 at 19:34
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.