Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I just bought a new Dell external display (U2312hm) for my MacBook Pro Retina.

The fonts appear to be very blurry. I've searched and found a solution here, but it didn't fix my problem. I ran the script supplied in the thread, followed all instructions and the problem remains (tried on 2 different rMBPs with 2 different U2312hm monitors).

here are real a few examples (the upper browser in each picture is chrome on VMware and the lower is chrome on OSX 10.8.5): enter image description here enter image description here

I tried different font smoothing configurations which failed to improve the problem. I tried using Apple's MiniDisplayPort to AVI and MiniDisplayPort to DisplayPort cables - no change.

What can I do?

share|improve this question
    
Awful choice of sample page for the second sample; couldn't you have found something less unpleasant? –  Chelonian Jun 24 at 15:31
add comment

5 Answers 5

Horray! I found a solution.

I bought the Apple Mini DisplayPort to DVI converter cable adapter instead of using HDMI, and my picture is much more crisp and clear.

enter image description here

My Retina display is still better, but it's a better screen. my HP monitor is now performing to is ability. For some reason, HDMI must degrade the video quality.

share|improve this answer
add comment

Image here shows a web page from Internet Explorer (top, on Parallels) and on OSX Chrome (Below). enter image description here

The problem you saw was not really a problem. It was the different way which Windows and OSX render their fonts (aliasing). Some people prefer Windows's sharp font, others prefer OSX style.

I hope I understood your problem correctly because what you showed in the image(not clear, not a screen capture but from a camera) was what I have noticed before.

See here for a comparison on the two algorithms for aliasing fonts.

share|improve this answer
    
This isn't the problem being described. I know very well the differences in font rendering between the Mac OS X and Windows platforms. What's actually happening is a problem with the signal sent from the Mac to the monitor. The Mac is using the wrong color space, and it screws up font rendering, somehow. Forcing the color space to RGB, by using the patch-edid.rb script, has completely altered the font rendering on my external display, from "crunchy" to smooth. Good explanation here: ireckon.net/2013/03/… –  Alderete Apr 22 at 10:15
add comment

The solution at http://embdev.net/topic/284710 worked for me.

Attach your display, download the updated patch-edid.rb, run ruby patch-edid.rb in Terminal and reboot. Voila!

Tested and working on both Mountain Lion and Mavericks with two U2713H monitors.

share|improve this answer
    
as I written in the post, this solution doesn't affect the font appearance. the problem remains. –  YSY Oct 24 '13 at 12:18
add comment

Have you tried toggling Use LCD Font Smoothing off and rebooting? To my eyes, it makes fonts on non-Retina displays look super thick and somewhat blurry, not unlike your photos. It's in System Preferences → General:

LCD Font Smoothing

share|improve this answer
    
I just took this exact screen shot..! –  beroe Oct 21 '13 at 20:15
    
unfortunately this setting did not fix the problem (tried changing to bigger font sizes too). –  YSY Oct 22 '13 at 8:03
add comment

Are you using the "Best Resolution for display" setting for the external monitor? I was forcing 1920x1080 and seeing a similar fuzzy look. I changed from the fixed resolution to Best Resolution (even tough they are the same), and my fonts are now smooth on my Viewsonic (at work) and my HP (at home) 24" monitors.

share|improve this answer
    
I'm using "Best for display" and still have this problem, I will add a photo to show the problem. –  YSY Aug 20 '13 at 13:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.