Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

iWork provides the keyboard shortcut Cmd-Option-Shift-V to paste text without it's original formatting. How can I get this or a similar shortcut key for Microsoft Word 2008 for Mac?

share|improve this question
    
The "PasteDestinationFormatting" does not provide unformatted text. It matches the text that is at the destination point. Unfortunately, stupid Word for some reason likes to create that destination format depending on its mood at the time. I just reassigned Command-V as per this hint, and Word pasted my text as 16pt bold text (all document text is Times New Roman 12 - explain to me how that happens?). –  Long-suffering Word user Feb 12 at 20:00
add comment

5 Answers

up vote 2 down vote accepted

I found the answer in this blog post

Create the AppleScript:

try
  set theClip to Unicode text of (the clipboard as record)
  tell application "Microsoft Word" to tell selection to type text text theClip
end try

Save in /Users/YourUserName/Documents/Microsoft User Data/Word Script Menu Items as Paste unformatted\mosV.scpt (the backslashed bit at the end of the filename provides the shortcut). Restart Word and you can now paste without importing extraneous styles with Apple-Alt-Shift-V.

share|improve this answer
    
I needed to use Automator to create a workflow which executed an applescript. Then I saved it with a .workflow extension, and it worked fine (albeit with a slight delay) –  Sam Barnum Mar 2 at 23:53
add comment

Answer to the same problem but for Microsoft Word 2011: how to assign pasting as unformatted text to Cmd+V.

share|improve this answer
add comment

There's a "PasteDestinatationFormatting" command.

Go to Tools > Customize Keyboard, then select "All Commands" in the left pane.

In Word 2011, the default keys are command-option-shift-v.

share|improve this answer
    
Must be in a different version of word. I see PasteFormat & PasteFromScrapbook, but not PasteDestinationFormatting. I am using 12.2.8 (101117). –  ericgorr Mar 9 '11 at 16:23
add comment

This blog post describes a method by redefining Cmd-V to a custom macro:

  • Unbind Cmd-V from standard “Paste”.
  • Record a macro for Cmd-V.
  • Fix the source code of the new macro (by replacing wdPasteDefault with wdFormatPlainText).

If you want to keep standard "Paste" functionality it might be better to use another key combination though.

share|improve this answer
add comment

We're looking for long answers that provide some explanation and context. Don't just give a one-line answer; explain why your answer is right, ideally with citations. Answers that don't include explanations may be removed.

If you assign a short cut key to "Paste Special..." it's just another quick DOWN and RETURN to paste without formatting.

share|improve this answer
1  
How do you achieve this? –  Rob Mar 20 at 18:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.