Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm a teacher in a classroom with 8, 9 10 and 11 year olds who each have a macbook or a macbook pro. Fun job. We have a standard 10.6.6 image with iWork '09 (4.03).

In previous images, iWork would ask to be registered thrice (it changed to 'Never Register' on the third time), and then stop bugging you; but now for some reason it won't stop asking us to register. It's a real hassle. I've repaired disk permissions, but that doesn't fix it. Any ideas how to stop it from asking us to register? Bonus points if I can roll it out using a terminal script via. remote desktop.

Thanks! enter image description here

share|improve this question

3 Answers 3

up vote 5 down vote accepted

I found this via google Disable iWork registration nag screen.

defaults write /Library/Preferences/ RegistrationHasBeenSent true

I have no idea if this will work for you. I wanted to point this out in case you hadn't tried it.

This blog was the first result in google from searching for iwork disable reg. If it doesn't work, you might see if there are more results that might help or a slightly different search that might provide something meaningful. In any event, good luck. I hope it helps.

share|improve this answer
Unfortunately I get this error: 2011-03-11 15:06:12.295 defaults[1155:903] Could not write domain; exiting - I'll have a little Google. I've just used the Apple SE for so long it's my first port of call, but you're right, google is always there too. – glenstorey Mar 11 '11 at 2:06
perhaps try defaults write ~/Library/Preferences/ RegistrationHasBeenSent true (e.g. in your user directory instead). – sorens Mar 11 '11 at 4:30
Great - that last comment works, but not via remote desktop for some reason. Thankyou! – glenstorey May 7 '11 at 3:19
The link is dead. On a freshly installed iWork '09 the /Library/Preferences/ is empty and changing it doesn't stop the repeated registration window. – daniel Azuelos Oct 23 at 17:34

To change the global settings (/Library/..., not ~/Library/...), you must run the command with sudo:

sudo defaults write /Library/Preferences/ RegistrationHasBeenSent true
share|improve this answer

The setting is a per user one. Every different user on a given Mac may register his E-mail.

You can force the registration to be considered as sent with:

defaults write ~/Library/Preferences/ RegistrationHasBeenSent true
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.