Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I fill out webforms on my iphone fairly often. I use autocomplete to speed this process along, and it works pretty well for the most part. However, for some reason, it always insists on using an @facebook.com email address in the email field.

I do not use Facebook for email. I never have, never will, and never want to. I do use Facebook for lots of other things, and thus, would prefer not to turn off iOS's Facebook integration, which seems to be the only workaround that googling has offered me.

How can I force auto-complete to use my preferred email address, rather than the one associated with my Facebook account?

share|improve this question
add comment

3 Answers

Open up your contact card that is linked to your autofill

Change the label on your facebook email to 'other' or something else and change the label on the email that needs to be auto filled to 'email' or 'home' if 'email' is not available.

If that doesn't work unlink facebook and link facebook again. Facebook should now be at the bottom.

Autofill should pick the top email address.

share|improve this answer
    
It won't let me change the label of the Facebook email, sadly. But I can just change the label of an email that's listed above it to simply 'email' if that'll fix it. I had an email labelled 'home' which it was bypassing to use the facebook account. –  LessPop_MoreFizz Aug 5 '13 at 12:49
    
According to this that should fix it. But if not try unlinking your facebook and linking that again. And if that doesn't work you could clear your autofill in settings->safari->autofill –  FLY Aug 5 '13 at 13:03
add comment

First, I created a new contact in my contacts for myself with just my email, and the other specific info I want used for autofill in it, using a name that was not at all similar to the one currently being used (i.e. "hello kitty" or something that you will be able to easily pick out).

Then, I went into Settings → Safari → Passwords & Autofill → My Info. Then type the name you previously created into the search box to choose it as the info you want used for autofill.

Voila! This worked for me.

share|improve this answer
    
Well, you'll want the contact to have your real name, or else it'll fill "Hello Kitty" in web forms! But this solution definitely does work. –  timothymh Nov 16 '13 at 16:53
add comment

I had the same problem, you need to go to System Preferences > Mail, Contacts & Calendars, select your Facebook account then untick the Contacts checkbox http://take.ms/AD4o8V

Then you can select any of the fields in your Contacts app and "reclaim" your desired main email address.

share|improve this answer
1  
Except that I want Facebook linked to my contacts. I would rather have that than autofill working properly. –  LessPop_MoreFizz Aug 6 '13 at 22:26
    
Understand, I took the compromise route, I unlinked from FB but kept all the contacts I got from it. –  demianturner Aug 7 '13 at 6:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.