Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sometimes I'm not able to change any of the custom images associated with contacts in the address book. If I quit and restart several times, it eventually works again.

What would cause this sort of thing to happen? I'm running on Snow Leopard.

share|improve this question
How are you changing the image? Is there any error message or other feedback? – g . Mar 10 '11 at 13:02
I've tried both double-clicking on the image while editing an entry, as well as Card -> Choose Custom Image. There's no popup error message and nothing obvious on the console. – Lorin Hochstein Mar 10 '11 at 15:56
Lorin - Did you ever get an answer on how to put photos into the 10.6.8 OS Address Book? I cannot get it to work. Interesting that for older contact cards that either already have a photo, or ones created more than 4 or 5 years ago, double clicking on the blue-squared photo location pulls down the menu that allows photos to be added, changed or adjusted, and activates the "make this my card," "clear custom image" and "choose custom image" options under CARD. For new cards just added, or those that are recent (i.e. those added into OS 10.6.8) clicking the photo box dos nothing and those options – user18492 Feb 9 '12 at 16:10
@DMcCullough - No, I upgraded to 10.7 and haven't had the issue anymore. – Lorin Hochstein Feb 9 '12 at 17:15

Type in terminal:

chmod -R 777 /private/var/mobile/Library/AddressBook

chown -R mobile /private/var/mobile/Library/AddressBook

It worked for me


share|improve this answer
I don't have a /private/var/mobile directory on my machine. – Lorin Hochstein May 16 '11 at 11:33
@Javier J: that's for iOS. lorin is asking for Mac OS X 10.6. – Sören Kuklau Aug 13 '11 at 19:37

I had similar issue now with Mavericks. Looked like it was just an issue with the one contact. Think I originally created it from mail item that I received. Deleted the contact and created a new one from with contacts seemed to do trick. Something in the create from Mail seemed to lock the picture. No time to investigate just posting my solution in case it helps someone.

share|improve this answer

I have that issue - pictures on Address Book (10.8.x) won't sync with my Exchange server. The ones that WILL let me change the photos, it turns out, are the contact cards stored in iCloud. That seems to handle everything just fine.

share|improve this answer

Easy solution: Select the bad contact in the list, copy it, paste it (while it is still selected). For me, that replaced the bad contact with one in which the photo can be edited.

share|improve this answer

Having the same experience on El Capitan, some contacts I can edit the picture, other's I can't the copy and paste routine from Dave worked great. To add a bit more detail.This appears to happen when the contact is stored on an account that doesn't support pictures, eg some exchange accounts.

Open the Contacts application on your mac, search or click on the contact you can't edit, then copy and paste without deselecting the contact. Easiest way I found was Ctrl-C then Ctrl-V This recreates the contact in icloud but only shows as one contact. The picture can then me added to the icloud version of the card.

share|improve this answer

To change the picture

Open text edit, do command-shift 4 and place the cross hairs over the center of the white page, drag till you have an avatar-sized box and release.

Go to your desktop or wherever your screen shots are saved, rename and save the file somewhere useful, then go to system prefs/accounts and change the image to the "white" picture.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.