Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My macbook pro has just stopped detecting my wireless router! The model of the router is NetGear DG834G. The problem is that everyone else in the house has no problem connecting with the network with his laptop or mobile device! Any ideas on how to solve that? My operating system is mountain lion. Thank you.

share|improve this question
I have to say here that my macbookpro detects other networks so it is not a hardware problem. – skiabox Jul 27 '13 at 13:51
This look like a wireless environmental problem. To make it simple, you might be in a dark corner of the wireless network you'd like to reach. Could you compare your accessibility with other computers in the exact same position and add this information to your OP? – daniel Azuelos Jul 27 '13 at 14:35
What do you get with: Apple Menu > About This Mac > More Info > System Report > Network > Wi-Fi – GEdgar Jul 27 '13 at 14:38
yeap, no difference! – skiabox Jul 27 '13 at 14:47
→ Skiabox: Are they (your NetGear wireless network and the one from your neighbours) on the same channel? – daniel Azuelos Jul 27 '13 at 15:30
up vote 5 down vote accepted

The first step would be to open the folder /System/Library/CoreServices and run Wireless Diagnostics to get to the Utilities window (⌘+2) and run a wireless scan to check on your base station and whether the antenna on the Mac is picking up signals similar to your other devices.

Wi-Fi Scan to show RSSI and Noise

You'll want to inspect your base station (match the BSSID with the Mac address for your wireless router) and ensure that your signal to noise ratio is better than all of the ones I have shown. Ideally, your RSSI should be greater than -80 dBm: -90 dBm is bad, -60 dBm is OK, and your channel not within 2 of a neighboring station).

From there, you could select performance or run the actual diagnostics or see if perhaps you need to select a channel with less interference.

Performance view - shows SNR

As you can see in this view, even with no wireless network connected, you can run the tool. Once you join your network, this performance view will help you getting connected. Once you are connected, you can monitor things here and lastly, use the Info button to see what alternate channels you might try to let your Mac work with your exact router and the competing devices that also interfere with each other.

share|improve this answer
I've tried to run the diagnostics but even these diagnostics need to connect to a network. – skiabox Jul 27 '13 at 14:30
In fact, it is designed to run offline since you can't really assume a network is running when you need to run Wireless Diagnostics. Perhaps I'm not understanding your problem or you're not understanding how to use this tool so I'll edit in some more pictures in the hopes it helps you or someone else with a similar issue. It could be you just need a repair on your Mac for it's software and/or hardware. – bmike Jul 27 '13 at 15:29
I changed wireless channel in modem/router from auto to channel 1 and voila!Everything works fine now! – skiabox Jul 28 '13 at 12:26

It's possible that the WiFi 'channel' option in your router configuration/administration panel is set to 'Auto' and it went to a channel above 11, which seems to cause a lot of MacBook Pro users a problem - for example, see here:

So try changing the WiFi 'channel' to 11 or lower, and see if that helps - seems to have solved my problems!

share|improve this answer
Afterward, and notwithstanding the lack of answer of skiabox, your diagnostic seems to be the right one. Typically the router was on channel 40 when the MBP is with a 802.11g card. These "automatic" settings for the dummies are just creating a flock of plain stupid problems. – daniel Azuelos Jan 8 '15 at 12:04
Manually changing the channel to 9 (previously 13) worked like a charm for my 2010 Macbook Pro, which was suddenly unable to detect the network since yesterday. Thanks! – Robbert Aug 16 '15 at 15:14
This should be acceptable answer. I was pissed bcz of this issue in my MacBook. Changing the channel from auto to 11 fixed the issue. – Rafique Mohammed May 29 at 7:38

Assuming someone did not reset the router or made it not broadcast its ID, lets try to use the Terminal to display wifi around you.

Open Terminal and copy paste this:

sudo ln -s /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resources/airport /usr/sbin/airport

you will be asked to enter your computer password

after that copy paste following and watch it work:

airport -s
share|improve this answer

Check your channel. If it's channel 12, it won't be visible, and if you're set to auto switch the channels, it could've picked up 12 on its own. Macbooks only detect 1-11 (just fixed my detect issue by switching the channel).

share|improve this answer

protected by Community Apr 17 '15 at 11:02

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.