Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I wake up my Mac I am presented with the login screen. I begin typing my password in the empty password text box.

After typing the first few characters, the password text becomes highlighted (selected) somehow thereby causing the next character I type to delete those selected characters.

For example, say my password is "password123"

  1. I press power and my Mac wakes up I type "passw"
  2. The password text becomes selected somehow
  3. I finish typing "ord123" and hit enter
  4. The password is incorrect since I am left with "ord123" in the password input box

Why is this and/or how can I prevent this from happening?

share|improve this question
    
I see the same behavior, but only when using LogMeIn to remote back to my computer. Never seen it any other time. Drives me nuts. –  Alex Jul 21 '13 at 6:17
    
I see the same described behaviour, and I can add a correlation point. I hadn't this problem on Snow Leopard and Lion, (I checked it back, since I have Macs running these versions). I have this problem on Mountain Lion, repeatdly and it is causing me a serious waste of time: too many rejected good password. –  daniel Azuelos Nov 3 '13 at 14:05
    
I remove my silly answer, which might have been relevant but is clearly not the right explanation here. –  daniel Azuelos Nov 3 '13 at 14:10
add comment

4 Answers

up vote 1 down vote accepted

This problem come from the order in which 2 important operations are scheduled to read a sensitive piece of information which is a password:

  1. lock exclusive access to the keyboard
  2. read characters typed at the keyboard

Apparently these 2 operations are scheduled the wrong way round:

  1. read characters typed at the keyboard
  2. lock exclusive access to the keyboard

The part of the kernel in charge of reading the keyboard is waken up before locking the keyboard. This is fully understandable when you want to be able to wake the system on any keyboard entry. But in such a case, a mechanism should clearly indicate to the user when the keyboard is safe to type a serious password and not wake up noise.

This wrong scheduling was apparently a small problem and not noticed by many users since the 2 operations are anyway scheduled in a small window of events (it's a question of one or 2 seconds here).

This small window of time to schedule these 2 operations is larger if you are just waking up your disk, or if your disk isn't fast enough for your fingers, or if you have too fast fingers. This is the reason why some people thought that this problem was created by hard disk drive (HDD) and suppressed by solid state drive (SSD). In fact the problem isn't suppressed by an SSD, it is just more difficult to exhibit. You should consider this as a fundamental bug in password reading which is hidden when using a fast enough disk or slow motion fingers.

share|improve this answer
    
Thanks for this in depth explanation. This makes a lot of sense. –  Matthew Nov 4 '13 at 0:03
1  
Security bug reported @ Apple: 15435841. –  daniel Azuelos Nov 11 '13 at 10:34
add comment

I know the behaviour you describe. In my case, I wake up my Mac by pressing a key and I just wait for a few secs before entering the password. The key I pressed to wake up my Mac and if I press any others in that first couple of seconds (I am often impatient to get my computer to wake up!) will get selected as you describe.

I think this is intentional behaviour by Apple, that any character typed before the password field is displayed and working is not treated as part of the password to be entered & so are deleted. The behaviour though is not a good user experience. I think a better experience should be that the characters typed before the text field is ready should not be added to the text field when it is ready, thus making it clear that characters entered before the text field is ready are ignored. The adding them & then selecting & deleting behaviour is just odd.

My answer I suppose is this. After waking your computer, just wait a couple of secs before entering your password. I've just learnt to do that without thinking about it because it works. But your right & if you have the enthusiasm report it as a bug to Apple.

share|improve this answer
    
This isn't the described behavior. –  Alex Jul 21 '13 at 6:19
    
I see what you mean. I wake my Mac by hitting the power button and the login screen comes up. Just hitting keys won't wake it (maybe this is a configuration option?). It would make sense if I did hit keys to wake my Mac that these keys wouldn't count towards my password. If this is indeed the "feature" I might like to turn it off altogether. –  Matthew Jul 21 '13 at 12:29
    
This is just what I end up doing - waiting a few seconds after hitting power and then entering my password so that half of it doesn't get selected and overwritten. –  Matthew Jul 21 '13 at 12:32
    
@Alex Yes, this is basically how it works. I think Sheffield Kevin is on the right track anyway. –  Matthew Jul 21 '13 at 12:37
1  
I have the same behavior here, usually any keys pressed before the internal and external disks spin up are lost. This would also explain why it isn't really a problem if you are using SSDs –  patrix Jul 21 '13 at 12:56
add comment

Does your Mac have a SSD (Solid State Drive) or Flash Storage?

I have a Macbook Pro that had this problem, and the only way to truly fix the issue was to upgrade it to a SSD. Solid State Drives resume from sleep faster than a hard disk drive, and hard disk drives will always lag a little when resumed from sleep. One thing to try to make it slightly faster would be to open up Disk Utility, select the name of your drive (Macintosh HD most likely), and select each of the buttons (please wait for each to finish and then click the next one):

  1. Verify Disk
  2. Repair Disk
  3. Verify Disk Permissions
  4. Repair Disk Permissions

Once you do that, restart your computer and see if it helps to decrease your resume times.

share|improve this answer
    
→ Sameet: Did you see a relation between this slow wake up time on an SSD and the OP: an automatic and unwanted text selection? –  daniel Azuelos Jul 20 '13 at 17:02
    
Yes. On a HDD, which was what I used to have, if I kept my computer on sleep for more than a few minutes, when I wake it from sleep, the problem occurs as Matthew described. After switching to an SDD, this problem does not occur. The only difference was the switch from a HDD to an SDD. –  sameetandpotatoes Jul 20 '13 at 20:29
    
I can't seem to find out if it's SSD. Under Hardware > Serial ATA there is a listing: "Medium Type: Rotational" so maybe that means it's HDD. To be sure though, I won't be buying a new hard drive to fix this issue. –  Matthew Jul 21 '13 at 14:09
    
That sounds like an HDD. To find out for sure, click the Apple Logo, About Mac, More Info, and then Storage, it will say Hard Disk Drive or HDD or something like that. Sorry for not being of further help, Matthew. –  sameetandpotatoes Jul 21 '13 at 15:32
    
Here I was trying to check property info of the disk and I found out that HDD is part of its name. Yes, its an HDD. Thanks. –  Matthew Jul 23 '13 at 20:26
add comment

One responder here mentioned only having this problem when using LogMeIn. For me, the problem would come up whenever I was using Splashtop (another remote-access tool) to access my computer.

The problem went away when I turned off the "Enable blank screen" pref (in the Security tab of the Splashtop prefs). Turning that off fixed a few other problems I was having with Splashtop also. I don't think that feature is completely ready yet...

Anyway, I hope that helps someone else that may be using Splashtop.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.