Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Though it doesn't happen often, I sometimes find myself in the situation where OSX will not respond to any commands.

The last time this happened I was closing a fullscreen VM - the app went away but then I was on an empty screen and wasn't able to switch away (the mouse still worked but not the brightness/volume keys).

Is there any way to escape from such a situation other than holding the power key?

(I only found a few shortcuts that are supposed to force quit but none of them worked. Some mentioned an "EJECT" key which I do not have on my MacBook Pro keyboard.)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

From the article at http://support.apple.com/kb/ht3411

Press Command-Option-Esc to force quit, it brings up a dialog so you can choose which app to quit.

Command-Option-Shift-Esc for three seconds will force quit the front-most application.

Here is another helpful article: http://osxdaily.com/2012/03/02/force-quit-mac-apps/

share|improve this answer
    
I find that these do not work - at least not in the three seconds mentioned- order of minutes possibly –  Mark Jul 16 '13 at 19:41
    
Thanks. However is there anything else in case the OS does not respond? (like logout/shutdown/...?) –  hcris Jul 16 '13 at 21:44
    
If the above commands do not work the only solution I know is a hard shutdown by holding down the power button until the machine turns off. In my experience, once the Finder is truly locked-up there are no commands like logout/reset/shutdown that will work as there is no Finder available to process them. –  Dave Nelson Jul 17 '13 at 14:11
    
Also keep in mind that if the Finder is busy, is in the middle of crashing, if another app is hogging all of the processing cycles available, it will take much longer for any command to take place. If there is an app that is crashing hard and the Finder is also crashing it is common for the Force Quit dialogs to never appear, there just isn't any processing cycles available for the OS to display it. –  Dave Nelson Jul 17 '13 at 14:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.