Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

The WiFi interface won't turn on when i press "Activate wifi" from the preferences neither from the status bar.

I tried restarting the mac,and reset the pram.

The Ethernet works fine and this is the result of ifconfig in the terminal:

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4> ether a8:20:66:37:81:d9  inet6 fe80::aa20:66ff:fe37:81d9%en0 prefixlen 64 scopeid 0x4  inet
192.168.1.131 netmask 0xffffff00 broadcast 192.168.1.255 media: autoselect (100baseTX <full-duplex,flow-control>) status: active

en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500 ether 5c:96:9d:89:fe:09  media: autoselect (<unknown type>) status: inactive

Is there anything I can try before initialize OSX?

share|improve this question
    
You mean the lock icon in the bottom left corner? Yes, it's unlocked... –  Lolloz89 Jul 14 '13 at 19:53
    
What is the syntax? "-bash: Airport: command not found" –  Lolloz89 Jul 14 '13 at 19:58
    
Got it: /System/Library/PrivateFrameworks/Apple80211.framework/Versions/Current/Resource‌​s/airport -I AirPort: Off Not so useful indeed! :D –  Lolloz89 Jul 14 '13 at 20:01
    
Uhm.. it's not done.. my wifi is still off! The airport command told me: AirPort: Off –  Lolloz89 Jul 14 '13 at 20:13
    
"sudo ifconfig en1 up" to turn it on! it will ask you for password. –  Buscar웃 Jul 14 '13 at 20:19
show 3 more comments

1 Answer 1

Found this:

  • Restart your mac.
  • Open "Network Preferences". On the left tab, look for wifi connection (usually named Wi-Fi).
  • Select the wifi connection, and disable that. To disable a connection, choose gear icon below the tab, and choose "Make Service Inactive".
  • After disabled, delete the connection. To delete a connection, choose minus (-) icon below the tab, left of gear icon.
  • Now that the original connection has been deleted, we must create a new wifi connection. Choose plus (+) icon, select "Wi-Fi" as interface, and you can name it anything as you want, it doesn't matter thought.
  • Apply the change. Once again, restart your mac.
  • After system reboot, voila ! your wifi should be working properly by now
share|improve this answer
2  
While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. –  George Garside Sep 30 '13 at 18:34
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.