Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm having a bad time trying to delete a subscribed calendar. I am running OSX 10.8.4 on my iMac and IOS 6 on iPhone and iPad. Whenever I delete this calendar it reappears, usually within a few seconds. I have tried deleting from each device and from iCloud, without success. Any thoughts or suggestions would be most welcome.

share|improve this question
    
Do those calendars belong to you (that is, did you create them) or are they subscribed calendars? Have you tried deleting them from icloud.com? –  jaume Jul 12 '13 at 13:04
    
Thanks for your comment, Jaume. I have clarified the question (see above) It is a subscribed calendar. And yes, I have repeatedly deleted it from my iCloud account, but it still returns. –  Peter Jul 13 '13 at 3:22
    
What is the original source of the calender. ie Google calender, Mac calender, Outlook calender...others... ? –  Buscar 웃 Jul 13 '13 at 6:47
    
How are you trying to delete the subscribed calendar? –  patrix Jul 13 '13 at 6:58
    
Thanks so much @Buscar and patrix for these responses. Original source of the subscribed calendar was iCal, it was created by me some years ago as a course calendar when I was an academic. I am now retired and the calendar is administered by my replacement at the university. I have repeatedly tried deleting the calendar (edit > delete) on each of my devices. I have tried switching off iCloud syncing of calendars on each device, deleting the calendar from iCloud, then renewing iCloud calendar sync. Nothing works! –  Peter Jul 13 '13 at 9:50
add comment

1 Answer

Assuming you use iCal (not specified in your question), then the Subscribed calender should appear under subscriptions.

UN-checking them will stop showing them.

If you trying to completely remove them then Right Click on the calender and Delete in the Pop up.

enter image description here


If above fails lets do the "brutal" method:

  1. First make an iCal backup: Click on each calendar on the left hand side of iCal one at a time highlighting it's name and then going to File Export > Export and saving the resulting calendar file to a logical location for safekeeping.

  2. Go to iCal > Quit iCal

  3. Remove the following to the trash and restart your computer:

Home > Library > Caches > com.apple.ical

Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache if present)

Launch iCal and test.

If the issue still persists at this point:

Remove the following to the trash and restart your computer:

Home > Library > Caches > com.apple.ical

Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache if present)

Home > Library > Preferences > com.apple.ical (There may be more than one of these. Remove them all.)

---NOTE: Removing these files may remove any shared (CalDAV) calendars you may have access to. You will have to re-add those calendars to iCal > Preferences > Accounts.

share|improve this answer
    
Thanks, Buscar, for this detailed information. I have tried the normal deletion method, with a few tweaks (see my comment above) and will now proceed to your 'brutal' method with the cache files. I have no other shared or subscribed calendars — in retirement, I am pleased to be able to manage on my Personal calendar only. Will let you know whether it works. Regards. –  Peter Jul 13 '13 at 9:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.