Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Whenever I plug my Microsoft Natural Ergonomic Keyboard into my MacBook Pro, I have to swap the Command and Option modifier keys. How can I prevent these keys from reverting to their default settings whenever I unplug the keyboard?

share|improve this question
    
Please provide more information about your OS X version. –  Martín Marconcini Mar 4 '11 at 20:08
    
Mac OS X 10.6.6 –  titaniumdecoy Mar 5 '11 at 4:53

3 Answers 3

up vote 2 down vote accepted

I assume you already know about the Keyboard Pref Pane. I had exactly the same problem with an Ergonomic and an Arc. The settings didn't stick with external keyboards.

Install KeyRemap4MacBook. It works for any Mac, btw. It remaps keys on all keyboards of a Mac - try to use Enter as Right-Cmd, e.g.

  1. Set Cmd to Alt etc. for all keyboards in KeyRemap4MacBook (both right and left).
  2. Switch the keys in the Keyboard Pref Pane for the internal keyboard. Et voilà!

I figured out that weird hack some time ago. It turned out to be rock solid. Only thing to remember: hardware based utilities such as SteerMouse use the 'real' keys, so you need to switch around some things.

share|improve this answer

thyx is right. Grab KR4MB here: http://pqrs.org/macosx/keyremap4macbook/ - No need to worry about it not getting updated as the dev is super responsive and is constantly tinkering with the app making it better with every release. Another note is that it's open source so if you know your way around you can make changes yourself but I doubt you will need to. It's great software, I have been using it for years and on a wide variety of keyboards with no problems that could not be easily amended by reading the prepared docs. Give it a try, if you use Safari check out his extension "keystroke." I wouldn't be able to use safari without it.

share|improve this answer

Thanks thyx & notme for suggesting KeyRemap4MacBook. Here are my enabled settings:

  • General
    • Don't remap an internal keyboard
    • Don't remap Apple's keyboards
  • Change Command_L Key (Left Command)
    • Command_L to Option_L
  • Change Command_R Key (Right Command)
    • Command_R to Option_R
  • Change Option_L Key (Left Option)
    • Option_L to Command_L
  • Change Option_R Key (Right Option)
    • Option_R to Command_R
share|improve this answer
    
Thanks for sharing your solution (as well as your question). I was rather puzzled by this preference pane's simply God-awful user interface, but being able to see how you did it helped me out. At least it's better than starting up DoubleCommand's 32-bit preference pane every time I connected or disconnected my Natural Ergonomic 4000 (which itself was still worlds better than the random kernel panics Microsoft's official drivers were causing - remind me to tell you about the time I contacted MS's tech support for help on that…). –  Garrett Albright May 19 '11 at 16:27
    
I'm glad you found my post helpful. I agree: KeyRemap4MacBook's UI is one of the worst I have ever used. –  titaniumdecoy May 19 '11 at 16:55
    
Also, for others who may encounter it… KR4MB does not respect the keyboard repeat rate/delay you set in the standard Keyboard control panel. Instead, you have to open up KR4MB's "Key Repeat" tab and set values in milliseconds. Yeah, no sliders… in milliseconds. Ugh. –  Garrett Albright May 20 '11 at 7:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.