Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I always thought I knew a fair amount about iPhones/iTunes etc but this has me stumped!

I have a 16 GB iPhone 5 running the latest version of iTunes on a Windows Laptop. I do not have iTunes Match.

Due to having 100gb of music on the laptop I have already 'checked' the following options in the iPhone 'summary'

  • Sync only ticked songs and videos
  • Manually manage music and videos

I then went into 'music' and unchecked all the artists, albums etc to the point it said 0 songs (in light grey next to where it says sync music)

So looking at that it should mean I have no songs selected, so none on my phone... but no!

It is still telling me I have 5gb of audio! I have gone back and forth applying​/syncing​/checking​/unchecking in the hope I have overlooked something but I am now totally stuck on what to try next.

All I want to do is remove all songs from the phone and then put some fresh music back on.

share|improve this question

5 Answers 5

Assuming you're running the latest iOS (iOS6)

From the Home Screen, go to Settings > General > Usage

Wait while it loads your apps, then select music.

Then tap 'Edit' and delete your music.

share|improve this answer

If it helps, I was struggling with this too - then realised Podcasts are counted under music! Clear out your Podcasts in the same way as above, et voila!

share|improve this answer

In my iPhone 5S I found…

  1. In Settings → General → Usage → Manage Storage → Music…

  2. Tap on Edit

  3. Tap on the red icon next to All Music and it will show the Delete Button.

  4. Tap on the button to delete all the music files from your device.

share|improve this answer

I was having the same issue. I don't know if you are continuing to have the same problem but I was trying everything I could think of. I tried selecting just a few songs and it would still have others on my phone!

Finally, I stumbled across the issue. Under the Music tab when you're looking at your phone on iTunes, make sure all of the artists and albums sections are unchecked, as well. That is where all my music selections were hiding.

share|improve this answer

I had the same problem where even though I click yes for it to erase everything so that I could resync my iPhone, none of the music was removed from my phone as it was removed from my iTunes.

I went to Settings → General → Usage, waited for my apps to load, chose Music, edit, then delete. Took two times for it to work, then I was able to freshly sync my iPhone with music from my iTunes.

I tried every other process and this is the only thing that worked. Highly recommend an external hard drive to back everything up to as it makes it so much easier when you get a new computer or new hard drive.

share|improve this answer

protected by grgarside 27 mins ago

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.