Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I am trying to turn on FileVault on my retina MacBook Pro (running OS X 10.8.4), and after going through the key generation it fails with a "Disk in use by driver" error, as shown:

FileVault Failed - The given disk is in use by a driver

I've got nothing running (I had quit all applications) except Finder, and no USB or external drives are connected, and I am connected to AC power.

So, what could be wrong?

share|improve this question
    
Two questions, your Retina MacBook is running Mountain Lion, right? Second, did you try to turn on FileVault on the built-in SSD? –  Shane Hsu Jul 1 '13 at 15:49
    
There are many paths to turning on file vault. Which are you using? –  bmike Jul 1 '13 at 18:21
    
@ShaneHsu yes to both answers –  codemonkey Jul 1 '13 at 22:03
    
@bmike the one through the tab in Security & Privacy in system preferences, I do not know of any other way –  codemonkey Jul 1 '13 at 22:04

1 Answer 1

up vote 3 down vote accepted

You can try using the command line version, fdesetup. The simplest method of doing so is opening Terminal (in /Applications/Utilities) and typing

sudo fdesetup enable

Once you put in your username(type it exactly as shown in the terminal window before the ":~" ) and password, it will give you a recovery key. Write it down and double check it! This is your only way back into the system if you forget your password.

Reboot the computer and the process should begin.

If that gives you the same error, you can try doing a deferred process.

NOTE TO ALL:

Do not do this method if you have a mac with a Fusion Drive in it.

To do so, open Terminal and type:

sudo fdesetup -defer ~/Desktop/recovery.plist

This will run full disk encryption at reboot, so everything will be closed. The user you are logged in as will be the default username/password used to unlock your encrypted drive. Since this method will not display the recovery key, it will be saved on your Desktop as "recovery.plist". Treat this as your password, it is just as powerful. Once you reboot, write this down somewhere safe.

Hopefully this works out for you, and as always, be sure to make an unencrypted backup before you do this, just to prevent any data loss.

share|improve this answer
    
Thanks for the reply Michael. I have tried the first option and got: ==== EFILoginCopyUserGraphics === Error: It appears that FileVault has already been enabled (-69695) Error: A problem occurred while trying to enable FileVault. I will try the second method now –  codemonkey Jul 1 '13 at 22:31
    
You can also try sudo fdesetup status if the second option does not work and post the response here. You can also try sudo fdesetup disable to force disabling FileVault –  Michael Dornisch Jul 2 '13 at 3:18
    
Thanks mate. I have already tried the second step and it has worked –  codemonkey Jul 2 '13 at 15:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.