Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My uses IMAP to fetch email from GMail. I use the standard settings given by the configuration wizard in OSX Mountain Lion.

The problem I am facing is that removes all incoming emails from the inbox. I can only find the emails in the folder All Mail. This happens in and in GMail (accessed through webmail), as well. The problem must be caused by, because it resolves when I removed my the GMail account from

Is there a way to debug this problem? Any way I can see what instructions is sending to GMail through IMAP?

share|improve this question
Did you check if you have any Rules enabled ? – Buscar웃 Jun 28 '13 at 7:27
Yes no rules enabled. By the way this problem started only a few days ago. Before the same setup was working soundly. – user52245 Jun 28 '13 at 7:32
Did you change any settings (on either Gmail or, install any new programs, or do anything else unusual a few days ago before the problem started? Have you recently updated to 10.8.4? – Bruce Jun 29 '13 at 2:17
Also - ping me if the debug logs aren't helpful. We can decide to open a new question to go over the logs or perhaps figure out a minor issue in comments here or below. – bmike Jun 30 '13 at 15:13

Debugging on OS X is fairly easy - especially in the case you describe where the problem is with one account.

  • Get the Incoming Mail server name from preferences (Mail --> Preferences... --> Accounts --> (your account) --> Incoming Mail Server) - it's likely something like or
  • Quit Mail
  • Open terminal and type this all as one long line (it's split here for readability):

    /Applications/ -LogActivityOnHost -LogIMAPErrors YES >& ~/Desktop/MailConnection.log &

The harder part becomes making sense of the volume of data being logged, but again it seems you have a good handle on the scope of the issue. I would take a gander at your IMAP and label settings in gmail preferences to be sure your account isn't suppressing those folders for IMAP delivery.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.