Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a Nordic/Norwegian keyboard. I'm sitting on an iMac with Mountain Lion and are remoting to a Windows 7 computer with Remote Desktop Connection. I can't find the < or > shortcut (pressing < gives a different character (pipe)). Does anyone know?

I am aware of this question and know how to find most other characters, having tried numerous combinations, but not the < sign. I also know I can get the character palette, but that is just too slow when I need it relatively often.

Edit: I do not have a numerical pad on the keyboard. This is the smallest version of the Nordic Mac keyboard and is the default delivered with an iMac in Norway.

Edit 2: Here is a picture of my keyboard: enter image description here

Edit 3: Thanks to @koivo I learned that < is called an angle bracket. I did some googling and found only one unanswered question asked at a different forum (ars technica). I have also tried all sorts of key combinations, but no luck so far.

Edit 4: I have now learned that using CoRD (which is slightly buggy and discontinued in development) or Royal TS (which cost money) will give me angle brackets (<) on the angle bracket key itself. However, I have added a bounty to see if it is possible to do with Remote Desktop Connection that comes with the iMac out of the box.

Edit 5: This is written after the correct answer and bounty has been awarded. Even though a shortcut is available, using the free version of Royal TSX is just a simpler solution, as stated in one of the answers!

share|improve this question
    
Could you try shift-","? –  daniel Azuelos Jun 26 '13 at 9:10
    
shift + "," gives me ";" which is what my keyboard says as well. –  Halvard Jun 26 '13 at 11:50
1  
you can always use Windows On-Screen Keyboard, just run osk.exe –  Guido Preite Jun 26 '13 at 12:01
    
@GuidoPreite +1 At least that saves time compared to using the character palette, but still I wish there was a keyboard shortcut. –  Halvard Jun 26 '13 at 12:05
    
→ Halvard: on your physical keyboard, is there a key between the left shift and the Z? –  daniel Azuelos Jun 26 '13 at 13:39

3 Answers 3

up vote 2 down vote accepted
+50

Try going to System Preferences:Language & Text:Input Sources. Enable and display the keyboard viewer to get a better view of the next steps.

The first step to try is to turn on the U.S. keyboard. This should cause shift+comma and shift+period to yield the desired characters, < and >, in place of ; and :. You can switch between keyboard layouts either using the flag menu that will appear on the right of your menu bar, or by setting keyboard shortcuts.

If switching to the U.S. keyboard layout doesn't work, enable Unicode Hex Input to allow the entry of any Unicode characters by holding down option and typing the hex code point. <alt/option>003c yields < (LESS-THAN SIGN) and <alt/option>003e yields > (GREATER-THAN SIGN). See http://www.unicode.org/charts/PDF/U0000.pdf for a table of common ASCII based Unicode characters. LESS-THAN SIGN and GREATER-THAN SIGN are the official Unicode names for the angle brackets.

For what it's worth, when I turn on, for example, a Swedish keyboard on my U.S. system, the key to the left of the number 1 offers < and >, as opposed to what I see in your picture. Showing the keyboard viewer should help clarify what to expect.

From the other question you reference there is also the suggestion by @Tom Gewecke:

Perhaps you could set up another keystroke to produce @ via system preferences/language & text/text/symbol and text substitution.

share|improve this answer
    
Switching to a U.S. keyboard (or an English keyboard) gives me < from shift + comma and > from shift + period as stated in this answer. Some minimal research gave me alt + shift as the shortcut to switch between language systems (from EN to NO and back). How could this simple solution have evaded me? :) Bounty well deserved. –  Halvard Jul 1 '13 at 6:46
    
For additional info: I was not able to get Unicode Hex to work, but this might be because of me. –  Halvard Jul 1 '13 at 6:48
    
For additional info II: When I replaced one key with < it worked on my iMac, but when I remoted in to the Windows computer the key was not replaced any longer. Perhaps if I replaced the key on the Windows machine it might have worked, but then I would have had to unreplace it when not remoting in. –  Halvard Jul 1 '13 at 6:50
    
Glad this worked out for you! Were you able to get Unicode to work locally? –  Steven McGrath Jul 1 '13 at 8:39
    
Yes, I got Unicode Hex input to work on my iMac. When I remoted in to Windows 7 it did not work though, and I was not able to enable Unicode Hex input on the Windows 7 machine. Thanks anyway! –  Halvard Jul 2 '13 at 6:31

Microsoft Remote Desktop Connection is not supported on anything newer than Snow Leopard 10.6 and if you use it long enough on newer versions of OS X you'll probably run into other issues besides this one such as random crashes from my own personal experience.

Royal TSX is indeed free (with limitations) and has a plugin using FreeRDP under the hood which supports newer versions of RDP configured to require NLA (Windows 7+, Server 2008R2+). My suggestion is that you re-evaluate your decision to stick with RDC, it's a dead end unless Microsoft decides to update it and it's not looking as if they will.

Quote from the Royal TSX site:

Royal TSX can be downloaded, installed and used for free without any time limit (no trial expiration!) and without a license key. In this mode, the following restrictions are applied:

You cannot have more than 10 connections per Royal TSX application instance. You cannot have more than 10 credentials per Royal TSX application instance. You can open only one Royal TSX document per application instance. AppleScript access is disabled. Also note that all the features of Royal TSX can be used without a license key. No other restrictions apply. To remove the above restrictions, it's required to obtain and enter a license key in Royal TSX.

share|improve this answer
    
+1 for very useful information about Microsoft Remote Desktop Connection and Royal TSX. I can confirm that Royal TSX works brilliantly and also gives me the < and > keys. (I can't give you the bounty though, as you don't answer the question the bounty was for) –  Halvard Jul 1 '13 at 6:38

As it is Windows you are accessing, try the Alt Codes (alt + numpad) alt + 60 for < and alt + 62 for >

Does that work for you?

Full list: http://www.alt-codes.net/

share|improve this answer
    
Unfortunately I just have a small Apple keyboard without the numeric pad, so I can't test out your suggestion. I tried it using the regular numbers (alt + (6 + 0)), but that did not work. –  Halvard Jun 26 '13 at 11:48
    
I have also tried alt + 0060 and alt + 0062 as I read somewhere, but that did not work either, unfortunately. –  Halvard Jun 27 '13 at 15:26
1  
@Halvard - Is it possible to change the keyboard layout within Windows? Or are other users bound to the current layout? –  koivo Jun 27 '13 at 15:37
    
I am the only user of the Windows computer I am remoting to, so I don't have to take any such considerations. I have an iMac at home, but an Hewlett Packard (hp) with Windows 7 at work to remote to. By the way, the key for < at work is to the left of Z, just as for the iMac. If I remote from my small Windows laptop the < key works fine. –  Halvard Jun 28 '13 at 13:47
    
@Halvard - Two more suggestions: ctrl + alt + < and alt + 7 - and I also found someone who had to use caps lock combinations for different brackets, like caps lock + ctrl + alt + some different numbers ... –  koivo Jun 28 '13 at 18:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.