Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My biggest problem is: cmd ⌘K (Connect to Server…) just doesn't work (neither does it exist in the "Go" menu in Finder). When I hit cmd ⌘K in Finder it just gives me an error beep (sounds more like a "boup"). I want to connect to a Windows network and it works fine on my 10.8 iMac at work (with cmd ⌘K and then typing the correct adress) but doesn't on my home MacBook white with 10.6.8 running. Why does cmd ⌘K not work here? Though on both machines the VPN connection works fine. How do I get the option to connect to a server via cmd ⌘K back?

Next thing I tried was connecting via command line with
mount -t smbfs //username:password@server\folder and
mount -t smbfs //username:password@server/folder.

Both didn't seem to work, just gave me the message:

usage: mount [-dfruvw] [-o options] [-t ufs | external_type] special node
       mount [-adfruvw] [-t ufs | external_type]
       mount [-dfruvw] special | node

Can you help me to get connected to the server?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

This question has some suggestions for enabling the missing menu option (that question is about 10.7, but worth a try).

I think the command line version isn't working because you need to provide a final argument, specifying where to mount the shared directory locally. On my 10.6.8 machine, man mount_smbfs gives this example:

mount -t smbfs //username:userpass@myserver/PUBLIC /smb/public
share|improve this answer
    
Woohoo, that one worked! Thank you!!! And as I see now, my question maybe could bet set to 'duplicate'... –  koivo Jun 28 '13 at 16:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.