Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Just bought the new MacBook Air, 13" and the new AirPort Extreme Base Station. I am curious as to how I get the max connection? Option + Click on my WiFi shows I am connected only using "n" and on the 2.4Ghz frequency. Why would it not be on "ac" and 5Ghz?

share|improve this question
    
Maybe this can help? Hold down the option key when selecting the radio mode in Airport Utility in order to view more options - such as forcing an "ac only" mode. –  gentmatt Jun 19 '13 at 11:44
    
That might help but would prevent other devices that don't support "ac" to connect –  FLY Jun 19 '13 at 12:25
add comment

2 Answers

up vote 3 down vote accepted

Operating at 5GHz means that (in the margin - there are other factors) 802.11ac will penetrate walls, ceilings, floors less well than 802.11n at 2.4GHz.

The AirPort Utility allows you to setup a separate Network Name for the 5GHz frequency (Wireless Tab / Click Wireless Options). This means that you can explicitly select whether to connect a device via n/2.4GHz or ac/5GHz.

If you do this you can use /System/Library/CoreServices/Wireless Diagnostics (via Option+Click on WiFi) described here: How to troubleshoot 802.11ac bandwidth problems (note don't continue with the default assistant - select Utilities from the Window menu) to examine the relative performance of ac/n from different locations.

In my case I observed that with clear line of sight ac reported a Tx Rate of 867 Mbps compared to 145 Mbps for n. In contrast, several rooms away ac dropped off to the extent that n had better performance.

Reverting the changes above (so both 2.4GHz and 5GHz have the same network name) and repeating the tests, saw the connection automatically switch from ac to n as signal dropped off.

In contrast, I've not (yet) seen an automatic switch from n to ac at a location where powering Wifi off/on gets (and holds) the ac connection.

While less than perfect in terms of "just doing the right thing", this is perhaps understandable - triggering a switch when quality drops below some threshold rather than continuously looking for a "better" connection when what you've got (albeit n rather than ac) is rated as "excellent". Of course this is an OS X behaviour ... perhaps Mavericks will address it?

share|improve this answer
    
nice insight, that was exactly what I asked couple a days ago in another question on Super User which got closed because of ambiguity –  Can Sürmeli Jun 20 '13 at 18:32
    
Thanks for the input! –  thatryan Jun 27 '13 at 23:39
add comment

It seems to be a global problem affecting a lot of new MacBook Air. You may need to wait a software update.

On Cult of Mac

share|improve this answer
    
A comment would be nice when downvoting. –  Matthieu Riegler Jun 26 '13 at 6:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.