Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been fiddling with my new Haswell macbook air (with Mountain Lion), and there's a difference between the "energy saver" settings on my macbook vs my 2011 iMac. On my iMac, there's a "Computer Sleep" as well as a "Display Sleep" setting, but the macbook air only has "Display sleep":

Macbook Air energy saver settings

When I don't use the computer for an hour or so, I want the display to go to sleep, but the computer should still be on, and shouldn't e.g. disconnect me from my chat sessions. How can I do this?

Thanks for your help.

share|improve this question
1  
MBA normally have the display for computer sleep, so you OS X ? has a problem. –  Buscar웃 Jun 18 '13 at 4:59
    
This may be a difference with the Haswell Macbooks, as the new CPUs feature new power-saving options. The Enable Power Nap option may keep your sessions from timing out in the way you seek... –  Dan J Jun 20 '13 at 19:02
    
same here with the same laptop. –  Hallucynogenyc Jun 22 '13 at 7:53

3 Answers 3

knodi was close, but pmset sleep 180 does not mean "180 x display sleep time" it simply means 180 minutes.

Before you change any of your pmset settings, I would take note of your current settings. If you enter this line in Terminal.app:

sudo pmset -g live | tee -a ~/Desktop/original-pmset.txt

it will show you the current pmset settings and it will also save a copy to ~/Desktop/original-pmset.txt so you can keep it as a reference.

Manipulating computer sleep time with pmset

If I want my MacBook Air to go to skeep after 60 minutes of idle time when it is plugged into wall/AC power, I can set that using:

sudo pmset -c sleep 60

Similarly,

sudo pmset -c sleep 0

tells my MacBook Air not to put the computer to sleep, even if the display goes to sleep.

If I wanted that same setting for when the MacBook is on battery power (not AC/wall power), then I would use

sudo pmset -b sleep 0

I can also set different sleep times for disksleep and displaysleep

(You can read more about pmset at https://developer.apple.com/library/mac/#documentation/Darwin/Reference/ManPages/man1/pmset.1.html or man pmset in Terminal.)

I would be very interested to know if sudo pmset -c sleep 60 (or whatever value you choose) actually works for a Haswell-based MacBook Air.

share|improve this answer

Maybe not the best answer but hope this might help a bit.

Not sure why you don't have the options I have. But it might be because you have a macbook air.

This is how it looks like on my macbook pro: enter image description here

I actually use an app called caffeine:

Caffeine is a tiny program that puts an icon in the right side of your menu bar. Click it to prevent your Mac from automatically going to sleep, dimming the screen or starting screen savers. Click it again to go back. Right-click (or ⌘-click) the icon to show the menu.

But as you can read this also prevents the screen from dimming.

share|improve this answer
1  
FWIW, my 2012 Air (2GHz i7) does have Computer Sleep, unlike the asker's 2013 Air. The settings panel looks otherwise identical. –  zigg Jul 9 '13 at 16:59

Here is a temp fix. Run the command "pmset sleep 180" to change sleep from 1 to 180 (180x of the display sleep time). This seems to work, macbook air won't fall at the normal sleep rate, 2x of the display sleep time.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.