Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm trying to change the icon size on my desktop. This should be easy via the view options. If finder would offer them.

I tried to get access to the options via the finder menu, cmd+j and I tried the right click on the desktop. But nothing worked. The menus just do not include a link to the view options.

enter image description here

enter image description here

Could anyone help? pit!

share|improve this question
    
Is the problem specific to your User account? Try creating an new account and login to it and see if the "Show view options" option is there. Alternatively, you can go to the "Go" menu > hold the "option" key > click on "Library" > "Preferences" > move the file "com.apple.finder.plist" to the Desktop > restart. See if it works. –  Melwan Jun 17 '13 at 12:01
    
hm, I'm afraid both options didn't help. still no view options ... but thx a lto for your hints –  John Sample Jun 17 '13 at 12:32
    
You mentioned that this your work account. Is the login managed by a server, or is the account local only to the macbook? –  Kent Jun 21 '13 at 7:06
add comment

4 Answers

It can be confusing at times.

Set finder to open as icon.

Then in finder while viewing icons you will find a small slider at the bottom right of the finder window. It looks like this:

enter image description here

EDIT: To change icon size on Desktop:

Click on: Show View options

in Finder with desktop background (close all other windows)

You will get this,

enter image description here

allowing you to change the Desktop icons sizes.

Alternative method to use making sure the Desktop is the TOP window (in focus) use this method.

enter image description here

If none of above works for you, check the date of the "com.apple.finder.plist" in Library, and if not very recent than Delete it.

share|improve this answer
    
Hey Buscar, thanks for your reply. After I set the status bar in finder to show I finally found the slider. Unfortunately, this only changes the icon size in the finder window but not on the desktop. Would you know how to do this? –  John Sample Jun 17 '13 at 7:07
    
Again, thanks for your answer. Yet, this is where I started: my Finder does not offer the menu item "Show view options". :-( –  John Sample Jun 17 '13 at 8:46
    
It looks like you are not on the desktop window or your Finder thinks so. Just out of curiosity, what is the ice cream icon doing. –  Buscar 웃 Jun 17 '13 at 16:20
    
The German Flag colors Ice Cream ? what is it ? –  Buscar 웃 Jun 17 '13 at 17:05
    
I replaced the standard folder icons with custom images (*.icns). Shouldn't be the problem as I have this on my private mac as well, where I don't experience issues with the view options. –  John Sample Jun 18 '13 at 11:46
show 2 more comments

It looks like there's something wrong with your installation; you should probably just reinstall OS X. (I've never encountered something where a specific feature in the Finder is missing though...)

Do you have any Finder hacks installed? Anything that would affect menus?

share|improve this answer
    
no hacks. all legal. It's my macbook at work. I didn't set it up and I'm afraid I won't be able to reinstall OSX. But honestly, I guess I can live without changing the icon size - though it's going to be hard. Very hard ;-) –  John Sample Jun 18 '13 at 11:49
    
Is your account an admin account? Go to "System Preferences" > "Users & Groups" > it should list all accounts and tell you the type as well. –  Melwan Jun 18 '13 at 13:03
add comment

Simply right click or control click on the desktop, not in the finder.

enter image description here

Click show view options:

enter image description here

two sliders at top control size and positioning of items on desktop. If the Show view options is greyed out. You have another problem. checked with standard account as opposed to administrator, but it is still allowed there. If you have account with usage restrictions it might be that.

If you are logged in as standard or admin user and it is still greyed out your finder plist is corrupt or you have some other add-in that is interfering.

share|improve this answer
add comment

This is not fixed by deleting com.apple.finder.plist -- found in your User Library/Preferences folder?

Since inputting Finder preferences again is relatively trivial, one usually just trashes the whole plist. Though if you are so inclined, you can open it in various editors and apps and make changes there.

Ignore Apples Reinstall answer, which they seem to be giving to everything these days - an unnecessarily huge step.

And yes, this is also the exact kind of issue where setting up a second user account, accessed by Fast User Switching, can tell you whether it's an account glitch, which are often not worth the time to track down. Though moving your stuff to second account is tiresome too.

Hope this helps, a bit confusing to answer below comments, which may have already answered.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.