Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I got an iPod Touch 2nd-gen. (Model # MC086LL) and all the fun games I find in the App Store require iOS 4.3. Is it possible for me to upgrade it to 4.3?

share|improve this question
2  
Does this post help isolate the OS versions for your iPod? apple.stackexchange.com/questions/55180/… –  bmike Jun 11 '13 at 19:10
2  
Or this? apple.stackexchange.com/questions/9362/… –  bmike Jun 11 '13 at 19:11
    
So 4.2.1 is the highest it can be upgraded? –  Orgional Poster Jun 11 '13 at 19:35

2 Answers 2

iOS 4.2.1 (8C148) is the maximum OS version it can be upgraded to so you won't be able to install 4.3 or newer OS using iTunes and Apple supplied versions of the software.

share|improve this answer

iOS 4.2.1 is the highest iTunes can install on that model. You can't get the latest greatest apps but there are tons of vintage apps available, even for models that can only run iOS 4.2.1 or earlier. The trick is finding them. This is one way, https://sites.google.com/site/appleclubfhs/support/advice-and-articles/finding-apps-for-older-devices Then there is an app to find these vintage apps, https://itunes.apple.com/us/app/vintapps-3.1.3/id639274910?mt=8&uo=4

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.