Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

To be clear, I can't install any Mac OS X update at the moment. I reformatted my disk and installed fresh off my Snow Leopard disk. I then continued to download 1.16GB worth of combined update (10.6.6) and I kept getting an "invalid checksum" error when attempting to open the DMG.

I'll be very clear on this to stop going around in circles. I have spent the last 2 days looking at this issue, trawling through forum posts, re-installing, verifying and checking my disk, trying 10.6.1 instead, reformatting again, doing a zero fill, the works. Anything that a forum seems to have suggested has not worked for me whatsoever.

Here's an output from my log:

Mar 1 19:37:43 Kieran-Seniors-MacBook-Pro installd[182]:
PackageKit: Install Failed: PKG: extracting ""
Error Domain=PKInstallErrorDomain Code=110 UserInfo=0x10011a1e0 "An error occurred while extracting files from the package “MacOSXUpd10.6.1.pkg”." Underlying Error=(Error Domain=NSCocoaErrorDomain Code=259 "The file couldn’t be opened because it isn’t in the correct format.")
NSFilePath = "/var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Tmp-/PKInstallSandbox-tmp/Root";
NSLocalizedDescription = "An error occurred while extracting files from the package "MacOSXUpd10.6.1.pkg".";
NSURL = "#MacOSXUpd10.6.1.pkg -- file://localhost/Volumes/Mac%20OS%20X%2010.6.1%20Update/MacOSXUpd10.6.1.pkg";
NSUnderlyingError = "Error Domain=NSCocoaErrorDomain Code=259 \"The file couldn't be opened because it isn't in the correct format.\"";
PKInstallPackageIdentifier = "";

Mar 1 19:37:43 Kieran-Seniors-MacBook-Pro Installer[173]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=110 UserInfo=0x1003f17f0 "An error occurred while extracting files from the package “MacOSXUpd10.6.1.pkg”." Underlying Error=(ErrorDomain=NSCocoaErrorDomain Code=259 "The file couldn’t be opened because it isn’t in the correct format.")

Mar 1 19:37:44 Kieran-Seniors-MacBook-Pro Installer[173]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

Mar 1 19:37:44 Kieran-Seniors-MacBook-Pro Installer[173]: IFDInstallController 14EE80 state = 7

Mar 1 19:37:44 Kieran-Seniors-MacBook-Pro Installer[173]: Displaying 'Install Failed' UI.

Mar 1 19:37:44 Kieran-Seniors-MacBook-Pro Installer[173]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.

Things I've done:

  1. Redownloaded any update version and tried to use them. 10.6.6 was downloaded 5 times altogether with no luck. I tried using prior versions such as 10.6.1 and 10.6.2, again with no luck.
  2. Redownloaded from a different system. That didn't work either.
  3. Reformatted the disk. That didn't do anything. I also zero-filled.
  4. Ran the disk repair utility

My system ran updates absolutely fine before this. Anyone got any ideas at all?


share|improve this question
One thing you haven't mention is what type of Internet Connection do you have and how do you connect to it? Airport? Ethernet? I know you've tried from another system, but I assume that the other system is using the same connection type/ISP. Could you please elaborate on that? – Martín Marconcini Mar 1 '11 at 20:48
Wireless, standard ADSL. Yes, the other system was using the same connection. I'm now downloading the updates from work instead. If these work, then I know it's something to do with my router (which could very well be the case). I honestly hadn't thought of that until suggestions by yourself and one other on here. – Kezzer Mar 2 '11 at 8:39
do tell us what sort of Wireless modem you have/router/Etc. and we'll start from there ;) – Martín Marconcini Mar 2 '11 at 12:51
I'll let you know when I get home ;) – Kezzer Mar 2 '11 at 15:14
I'd try some more debugging before replacing the router. For example, is your router separate from the ADSL modem? If so, I'd try connecting the Mac straight to the modem, and see if that works. I've also had ISPs that actually tamper with the data in HTTP connections -- bloody annoying. – Gordon Davisson Mar 2 '11 at 15:19
up vote 5 down vote accepted

Sounds like some sort of silently corrupted download (I had an old router that did this occasionally). Try a different connection using completely different modems, routers and access points. Maybe even a different internet provider at a friend's house or office.

share|improve this answer
Your comment I had an old router that did this occasionally, I think you may be right y'know. The reason I re-installed my OS was because my interwebs was not only going super slow but it also images downloaded would just look corrupt. This happened on my iPhone too. – Kezzer Mar 2 '11 at 8:25
I downloaded the files at work, then tested them at home and it worked fine. Re-downloaded them at home and it failed. It's either my router or my microfilter. Both of which I have spares and will test tonight. – Kezzer Mar 3 '11 at 16:24

The issue is "The file couldn’t be opened because it isn’t in the correct format.".

I would try the following steps:

  1. Download using the "Software Update" program, not manually. Perhaps "Software Update" will do something differently, or the manual version is including something that shouldn't be included

  2. Find out the md5 hash of the DMG you are downloading. Verify this. If the md5 hash doesn't match, then there is a problem with the download. Try downloading with a different browser. Try downloading via a different ISP.

  3. If the md5 hash matches and you get this error, that means one thing. If the md5 hash doesn't match, then this error is expected, and this means something else. You need to know which it is. Leave a comment and further debug steps can be considered at that point.

share|improve this answer
Step 1 was the first thing done, didn't work. Not sure how to do step 2. – Kezzer Mar 1 '11 at 21:00

This really sounds like a corrupted download problem -- the "invalid checksum" and "The file couldn’t be opened because it isn’t in the correct format." errors strongly point to this. Check the image file's size and SHA1 hash (note: Apple includes the hash in their download pages, e.g. here). Here's what I get on the 10.6.6 combo update (in disk image format):

$ ls -l MacOSXUpdCombo10.6.6.dmg 
-rw-r--r--@ 1 gordon  staff  1054916500 Jan  6 04:10 MacOSXUpdCombo10.6.6.dmg
$ openssl sha1 MacOSXUpdCombo10.6.6.dmg
SHA1(MacOSXUpdCombo10.6.6.dmg)= 868768cbc88db1895161f74030e98e8ce2303151

If your downloaded files don't match this length and/or hash, start digging into what's going wrong with the download. Do all of you downloaded files have the same lengths and hashes as each other (i.e. how consistent is the damage)? Try downloading with different browsers, via different internet connections, etc (you might want to use a smaller test file, like the 10.6.1 update, if you find one that shows similar errors). Look for a pattern in the errors and try to isolate where the problem's coming from.

share|improve this answer
So I tried the 10.6.1 update literally 10 times, on the tenth time it worked fine. This suggests to me that downloads are becoming corrupt. New router time methinks! – Kezzer Mar 2 '11 at 8:26

It wouldn't hurt to run Apple Hardware Test from the disk that came with your Mac. I had this happen once with an Apple update back in the 10.4 days and it turned out that I had a bad RAM chip.

share|improve this answer

hello Go to this webside and download the upgrade, then install it as an dmg file..


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.