Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm having an issue with my 2010 MacBook Pro. It started crashing a lot a couple of months ago, eventually even with kernel panics. Sometimes after a crash, during the next boot, it would display a progress bar below the Apple logo on the grey screen, similar to those you see during firmware updates. If that happened, the booting sequence would take a couple of minutes and would only finish after the progress bar was filled. It got progressively worse. One day I got a kernel panic, the same progress bar appeared during the next boot, but in the very beginning of the process the MacBook just shut down. I tried everything I could, including resetting PRAM/SMC, using a boot disk to check the internal HDD, fix permissions, etc. .. no use. So I reset everything from a Time Machine backup. Everything seemed to work (albeit with even more application crashes and a few kernel panics) for a few weeks, then BOOM - it won't boot again. This time I suspected a hardware issue, especially after taking out the internal HDD and using an enclosure to restore some files that were not backed up on Time Machine - when I plugged it in through USB the OS X complained that the disk couldn't be repaired and although files are accessible, the file system is read-only. So I got a brand new hard drive and did a full clean OS X reinstall. Two weeks later, the same issue :( It is very, very frustrating. I am NOT restoring through Time Machine another time. I want to find out what's going on here. Any suggestions?

Since I can't boot I can't give you the full hardware profile, but it's something along the lines of a Core 2 Duo CPU @ 2 GHz, 8 GB of RAM, OS X 10.8.4.

Any help or advice would be greatly appreciated. My warranty ran out so I really don't want to take this thing to a repair shop. Thank you!

EDIT. After a clean re-install of Mountain Lion the Macbook has been working alright for a while but lately started randomly shutting down with a kernel panic again. Here's a system report of the latest one:

Interval Since Last Panic Report: 509187 sec Panics Since Last Report: 1 Anonymous UUID: 42F83C67-5AAC-381B-983D-7209C27822B4

Tue Aug 13 18:39:27 2013 panic(cpu 0 caller 0xffffff800b8f3458): "hfs_swap_HFSPlusBTInternalNode: unrecognized catalog record type (0x0000; record #19)\n"@/SourceCache/xnu/xnu-2050.24.15/bsd/hfs/hfs_endian.c:704 Backtrace (CPU 0), Frame : Return Address 0xffffff80f317bd50 : 0xffffff800b61d626 0xffffff80f317bdc0 : 0xffffff800b8f3458 0xffffff80f317be10 : 0xffffff800b8f29b5 0xffffff80f317be60 : 0xffffff800b8e7c04 0xffffff80f317bea0 : 0xffffff800b71a27a 0xffffff80f317bf90 : 0xffffff800b71a92f 0xffffff80f317bfb0 : 0xffffff800b6b3137

BSD process name corresponding to current thread: kernel_task

Mac OS version: 12E55

Kernel version: Darwin Kernel Version 12.4.0: Wed May 1 17:57:12 PDT 2013; root:xnu-2050.24.15~1/RELEASE_X86_64 Kernel UUID: 896CB1E3-AB79-3DF1-B595-549DFFDF3D36 Kernel slide: 0x000000000b400000 Kernel text base: 0xffffff800b600000 System model name: MacBookPro7,1 (Mac-F222BEC8)

System uptime in nanoseconds: 67415599512099 last loaded kext at 59533332476697: 4.1.23 (addr 0xffffff7f8d8ec000, size 16384) last unloaded kext at 59632872040785: 4.1.23 (addr 0xffffff7f8d8ec000, size 12288) loaded kexts: com.bresink.driver.BRESINKx86Monitoring 9.0 1.8.4 1.9.5d0 1.60 100.12.87 2.3.7fc4 122 2.3.7fc4 4.1.4f2 2.0.3d0 1.0.0d1 4.1.4f2 7.0.0 3.4.5 1.0.0 1.6.0 3.0 8.1.2 3.5.10 170.2.5 1.1.11 3.0.3d1 237.1 320.15 237.1 1.0.0d1 1.0.0d1 34 3.1.7 3.5.5 404 2.3.1 3.6.1b4 5.5.5 1.7 2.5.2 5.2.5 5.5.0 615.20.17 4.9.6 161.0.0 1.5 1.8 1.7 1.9 1.7 1.6 196.0.0 4.0.39 2.1 196.0.0 2.3.7fc4 1.8.9fc11 1.6 2.2.5 4.1.4f2 2.3.7fc4 2.3.7fc4 86.0.4 10.0.6 4.1.4f2 1.0.0 1.0.11d0 5.3.0d51 1.0 8.1.2 8.1.2 3.4.5 1.0.4 1.0.11d0 2.3.7 2.3.7 3.1.4d2 237.3 5.2.5 3.5.5 3.5.1 3.5.5 1.7 1.7.1 1.7.1 5.5.5 5.2.5 2.5.1 3.5.5 1.0.2b1 5.5.5 2.3.1 5.6.0 2.2.9 530.4 3.0 4.5.5 1.7 1.8.1 1.1 220.3 1.0.0d1 7 345 1.8 28.21 1.7 2.7.3 1.4 1.0

share|improve this question
What did your Hardware test show? Did you try any of the booting options like safe mode, verbose mode ect.. – Buscar웃 Jun 11 '13 at 3:01
I haven't tried verbose boot yet. Safe mode didn't help back then though .. – dreddy Aug 14 '13 at 6:32
I'm not an expert, but I think it might be BRESINKx86 causing this. Try uninstalling any hardware monitoring apps – spuder Aug 14 '13 at 6:47

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.