Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I go into the System Preferences, Firewall, then Firewall Options. I can't select the "File Sharing (FTP)" entry to remove it. How can I?

enter image description here

Update: I'm running OS X 10.7.5, and nothing is enabled in the Sharing preference pane. At some point I must have turned on an FTP daemon for some testing, and forgot about it. I can do this:

$ ftp localhost
Trying 127.0.0.1...
Connected to localhost.
220 127.0.0.1 FTP server (tnftpd 20100324+GSSAPI) ready.

Turns out I could shut it off with:

sudo /bin/launchctl unload -w /System/Library/LaunchDaemons/ftp.plist

I still feel like I should have been able to block it in the firewall preferences pane.

share|improve this question
    
Go to the program that created it and do it form there. –  Buscar웃 Jun 11 '13 at 3:04
    
Is that controlled from the "Sharing" preference pane? I don't see FTP as a sharing option in Sharing preferences in Lion, but perhaps it was/is in a different version? I would still expect to be able to change firewall settings for it. But when I tried just now, I am not able to select either of the two items that appear in my settings. (web sharing and ssh) –  Tim B Jun 11 '13 at 12:44
    
@TimB: Apple dropped FTP support on OS X Lion, I guess the OP uses Snow Leopard or older. –  jaume Jun 11 '13 at 12:58
    
That was my guess, that for services delivered as part of the OS, that you're supposed to turn them off instead of configure in the firewall. I'd prefer finer granularity, such as restricting access to specific hosts or networks, but that isn't provided by the OS-X firewall. –  Tim B Jun 11 '13 at 13:01
    
I'm on 10.7.5. I'll update the question. –  Rob N Jun 11 '13 at 14:02

1 Answer 1

up vote 5 down vote accepted

OS X automatically creates firewall entries when a service (like AFP or SSH) is started through System Preferences.

That's handy, because you don't have to bother with firewall rules. The OS configures the firewall as necessary for the selected services to work. The downside is that those entries can't be edited or removed from within the Firewall pane, you need to stop the service instead, which is somewhat counterintuitive.

Could it be that you have enabled FTP file sharing in System Preferences > Sharing?

If you are using Mac OS X Leopard or Snow Leopard you need to uncheck "Share files and folders using FTP", the firewall entry will then go away (credit: picture from eHow):

enter image description here

(Apple dropped FTP support on OS X Lion, though it can be enabled and disabled through the command line:

  • To enable and start the service:

    sudo launchctl load -w /System/Library/LaunchDaemons/ftp.plist
    
  • To disable and stop it:

    sudo launchctl unload /System/Library/LaunchDaemons/ftp.plist
    
  • To start/stop it when the system is running:

    sudo launchctl start com.apple.ftpd
    sudo launchctl stop com.apple.ftpd
    

)

share|improve this answer
    
Yup, that's it. Thanks. I didn't enable it in Sharing panel, but I did enable it with that launchctl command. (I updated my question to mention that, before I read your answer.) –  Rob N Jun 11 '13 at 14:14
    
Thanks, that explains everything. I've added the commands to enable, disable start and stop the FTP service from Terminal. –  jaume Jun 11 '13 at 14:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.