Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I'm in a phone call, I still get alerts for emails and texts. The noise will play and, if the phone is on Speaker, it will vibrate -- often leading the person I'm talking to wonder what that weird noise was.

Surely there must be a way to silence the phone while you're talking on it. It's very distracting to have beepings going off right next to your ear!

share|improve this question

4 Answers 4

up vote 6 down vote accepted

Looks like there is no setting to silence alerts during a call.

https://discussions.apple.com/message/16904276#16904276

There's no phone setting to silence alerts during phone calls. You can suggest this to Apple: http://www.apple.com/feedback/iphone.html

share|improve this answer

Set Settings > Sounds > Vibrate on Silent to OFF; then while on the call you can flip the hardware switch to Silent. This will disable all sounds and vibration.

share|improve this answer
    
This is indeed what I ended up doing. Sounds counter-intuitive, but it works best for me. Thanks. –  Django Reinhardt Jul 3 at 13:14

Quickest way to shut off text tone, or any other, is to tap volume up or down one click, this cancels tones. Also including when text tone wont stop after entering text from home screen (notifications) there's no need to play with the notifications setting all the time. You'll see others mention to reboot holding home and sleep simultaneously to do stop run-on tones, doesn't last or work most of the time.

share|improve this answer

download a silent ringtone. Set your phone alerts to this ring tone. its the only way.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.