Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I'm new to OSX and running Mountain Lion in a Virtual Box VM. Xcode was running fine and I managed to create a simple Hello World App. I restarted the VM and when I tried to reopen my project Xcode crashed. I didn't think anything of this at the time but every time that I have relaunched Xcode since, it has frozen at this stage:

enter image description here

The CPU goes up to 95%ish usage and I have to force quit Xcode.

The following is in Xcode_Timestamp.hang:

Date/Time:       2013-06-07 12:02:37 +0100
OS Version:      10.8 (Build 12A269)
Architecture:    x86_64
Report Version:  11

Command:         Xcode
Path:            /Applications/Xcode.app/Contents/MacOS/Xcode
Version:         4.6.2 (2067.2)
Build Version:   2
Project Name:    IDEApplication
Source Version:  2067002000000000
App Item ID:     497799835
App External ID: 15055625
Parent:          launchd [121]

PID:             353
Event:           hang
Duration:        0.88s
Steps:           9 (100ms sampling interval)

Hardware model:  MacPro3,1
Active cpus:     1
Free pages:      433637 pages (+16260)
Pageins:         1 pages
Pageouts:        0 pages


Process:         Xcode [353]
Path:            /Applications/Xcode.app/Contents/MacOS/Xcode
Architecture:    x86_64
Parent:          launchd [121]
UID:             501
Task size:       175291 pages (-18383)
CPU Time:        0.456s

And in system.log:

Jun  7 12:16:07 imorelaptop.hkc2k3.local Dock[136]: no information back from LS about running process
Jun  7 12:16:17 imorelaptop.hkc2k3.local WindowServer[86]: CGXDisableUpdate: UI updates were forcibly disabled by application "Xcode" for over 1.00 seconds. Server has re-enabled them.
Jun  7 12:16:31 imorelaptop.hkc2k3.local WindowServer[86]: disable_update_likely_unbalanced: UI updates still disabled by application "Xcode" after 15.00 seconds (server forcibly re-enabled them after 1.00 seconds). Likely an unbalanced disableUpdate call.
Jun  7 12:16:39 imorelaptop.hkc2k3.local WindowServer[86]: reenable_update_for_connection: UI updates were finally reenabled by application "Xcode" after 23.15 seconds (server forcibly re-enabled them after 1.00 seconds)
Jun  7 12:17:11 imorelaptop.hkc2k3.local sandboxd[461] ([38]): mds(38) deny mach-lookup �#�:�*��;�j�Z��=�����~�הz�Q�F���N�m�mR���>wD+֍�T#���)�`�ثw�T78۲��r���-�j�&��ň����P�6EAM-�0b
    ���Q��Xh�R��S�^��
Jun  7 12:17:11 imorelaptop kernel[0]: Sandbox: sandboxd(461) deny mach-lookup com.apple.coresymbolicationd
Jun  7 12:17:11 imorelaptop.hkc2k3.local sandboxd[461] ([38]): mds(38) deny mach-lookup �#�:�*��;�j�Z��=�����~�הz�Q�F���N�m�mR���>wD+֍�T#���)�`�ثw�T78۲��r���-�j�&��ň����P�6EAM-�0b
    ���Q��Xh�R��S�^��
Jun  7 12:19:51 imorelaptop.hkc2k3.local WebProcess[306]: CoreAnimation: unhandled combiner function: 11

I have tried restarting my VM, increasing the RAM to 4GB (from 2GB) and reinstalling Xcode but still experiencing the same issue. I have also tried opening specific apps and files in Xcode, but the application still hangs at the same point.

share|improve this question
    
Begin with software updates from Apple –at least, from OS X 10.8 to 10.8.4. What type of Mac is the host? –  Graham Perrin Jun 7 '13 at 18:24
    
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.