Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I was working on my iPhone 4 with iOS 4.2 (the last one) for a while, when I called my phone operator to unlock the simlock. I followed the procedure, and I saved of my iPhone with iTunes, then restored it, then restored the backup with iTunes (last version). I didn't do anything special but followed the path given by iTunes on a reset / restore procedure.

After the restore procedure, some apps that I have been using for months did not get installed. According to iTunes the two reasons are:

  • Missing signature,
  • or Resources modified.

This also happens with newly downloaded applications after the reset.

My iPhone is not (and wasn't) jailbroken, and I don't understand what happened.

How may I solve this problem, without loosing datas, apps, music or photo libraries, or need to reinstall everything from scratch app per app ?

Some additional notes:

  • Any app that I download now that doesn't want to install from iTunes, can be correctly installed when downloaded directly on the iPhone. And no sync problems with iTunes.
  • Even updating a working and installed app can cause the problem.
  • New error with an app download from iTunes : "Unknown error 0xE800000B"
  • No music (nor anything else) is displayed in the iPod app, but iTunes shows the music, podcatsts, ... as present on the iPhone.

With BitDefender fully deactivated (as it cannot be quit), and ZoneAlarm shut down, it does not change anything. Not a surprise as they where both activated days ago and everything was working fine before the restore procedure.

share|improve this question
    
Have you ever used other means to install apps other than your own iPhone and your own iTunes? –  Cawas Mar 1 '11 at 13:40
    
@Cawas : I never did –  Oliver Mar 1 '11 at 19:21

1 Answer 1

up vote 0 down vote accepted

Problem solved : was a conflict with "ZoneAlarm Free" Don't know why it hasn't been resolved the first times I had deactivated it. But now, when I shut it down, no more problem with the sync except some rare apps that may really be corrupted I guess.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.