Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Since a couple of hours, when I try to run iTerm2.app, it opens a window, says

## exec failed ##
login No such file or directory

and closes rather fast. Running Terminal.app works and if I run /Applications/iTerm2.app/Contents/MacOS/iTerm from it it works just fine. Any ideas what's going on or how to fix it?

share|improve this question
    
I want to point out that iTerm2 is still in the alpha release stage. –  Fake Name Feb 28 '11 at 3:36

2 Answers 2

Sounds like your Default terminal has it's initial working directory set to some directory that no longer exists.

Try trashing your iTerm2 settings and starting from scratch. To delete your bookmarks and all other settings move the file ~/Library/Preferences/com.googlecode.iterm2.plist to the Trash.

share|improve this answer
    
@JPabloFernandeze: Or, if you have xcode installed, you could do open ~/Library/Preferences/com.googlecode.iterm2.plist in terminal and edit the preferences file directly so you don't have to trash all your settings. –  Robert S Ciaccio Feb 28 '11 at 1:09
1  
I've deleted it and everything that had to do with iTerm. I've re-download a new version and the problem is still persisting. –  J. Pablo Fernández Feb 28 '11 at 5:35
up vote 2 down vote accepted

The problem was .MacOSX/environment.plist. I didn't expected it to be the problem because I changed several days ago, but it seems it doesn't get re-loaded until you reboot.

I'm not 100% sure, but I think the problem was that I was trying to use the PATH variable to define it, I had this:

PATH => $PATH:/another/one

I've replaced that with a complete path and no $PATH variable, rebooted and now it's working.

share|improve this answer
    
The use of $PATH:/blah is safe if $PATH is undefined. I would add that back. More likely your reboot solved the problem, not the edit. With the $PATH removed from $PATH:/blah you may not get PATH settings made at the global level propagated to your user environment. –  Ian C. Feb 28 '11 at 14:13
    
@Ian: it doesn't work with $PATH. I put $PATH in, reboot, fail, remove, reboot, works. Does it work for you with $PATH? –  J. Pablo Fernández Mar 1 '11 at 5:32
    
Pablo: I can't even find a file with that name on my system. Comment was more to say that setting a path with an append or prepend, blindly, is safe (at least in shells). –  Ian C. Mar 1 '11 at 14:54
    
@Ian: You have to create the file if it doesn't exist. There's a nice tool for it: apple.com/downloads/macosx/system_disk_utilities/… stackoverflow.com/questions/5053022/… Note that it isn't a shell config file, it's a plist and it seems to work differently. –  J. Pablo Fernández Mar 2 '11 at 6:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.