Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Well, I think I really messed things up :) While trying to build the NumPy Python math module with Intel's Math Kernel Library (MKL), I was running into some problems with the Accelerate and vecLib frameworks overriding the MKL. At any rate, I decided it would be a good idea to rename /System/Library/Frameworks/Accelerate.framework and /System/Library/Frameworks/vecLib.framework temporarily. Nothing happened after moving Accelerate.framework. However, after entering

sudo mv vecLib.framework/ vecLib.framework.old

I got the following error:

sudo: unable to initialize PAM: No such file or directory

Oops. Unfortunately, the mv command worked, but now when I try to use sudo I get the same error, but the commands don't work. When I tried to rename vecLib through Finder, I get:

The operation can’t be completed.
An unexpected error occurred (error code -8076).

which apparently is some sort of permissions error.

So, my question is how can I get sudo working again? App Store.app won't even run, so I can't reinstall XCode (which is apparently where vecLib.framework comes from) or anything else. I'm afraid to reboot because I'm worried the computer will hang, whereas (as you can tell) at least it's working for now, albeit without any elevated permissions capabilities.

Any suggestions?

BTW, I'm running 10.8.3.

share|improve this question
    
In Unix & Linux: sudo: unable to initialize PAM: No such file or directory (2013-05-26) –  Graham Perrin Jan 18 at 8:37

1 Answer 1

up vote 1 down vote accepted

Just try restarting. Even if you can't start up normally, you can still probably start up from the recovery partition or in single user mode.

If nothing else works, try doing an upgrade install of OS X by starting up from the recovery partition and choosing Reinstall OS X. It downloads an OS X installer and replaces some system files with the initial versions. I have done it twice so far and it fixed multiple issues both times, so I have started to consider it as a troubleshooting step (but no-one ever does it when I recommend it here).

share|improve this answer
1  
Single-user mode did it. I wasn't aware of it on OSX, although I vaguely remembered using it in my Linux 1.1 days after I did some more googling on Sunday. I was able to fsck the appropriate partition and mount it, then rename the directories back to what they were supposed to be and reboot with no problems. Thanks for the help! –  MattDMo May 28 '13 at 17:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.