Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My SD card slot on the latest Macbook (Mid 2012) won't mount my SD card. The SD card doesn't appear in Finder, Disk Utility, Image Capture or anywhere. I know it's not a software problem, because nothing changed before and after. How do I fix it?

share|improve this question
up vote 46 down vote accepted

I blew hard in the SD card hub. Now it is working fine.

share|improve this answer
Wow. That worked! I guess we're back to the days of the NES. – hepcat72 Oct 17 '15 at 13:36

This thread says that there's a switch in the SD card slot that detects when a card is inserted, and it can get clogged by dust or jammed or something. If you play around with a toothpick (or anything that fits in that hole), it'll fix your problem. Toggling that switch helps.

share|improve this answer
So your issue is fixed? – demure May 24 '13 at 15:38
Yeah. I only commented because it was a hard bug to find, and much prefer Stack Exchange over some random forum. – Scott May 24 '13 at 20:22

for me sticking the SD card in and pulling it a bit out again ( just a few mm ) seems to get it mounted. There's even a video that explains how to put it in and pull it out a bit here

But I find that putting it in under an angle works better: Sticking the card in under a angle with the cut off corner against the top of the SD slot and then pushing the card in seems to get it mounted every time.

share|improve this answer
+1 for sticking it in under and angle: works reliable up to this point. – 0x6d64 Jan 6 '15 at 17:13
-1 for how ridiculous it is that you pay a premium for this hardware and then have to stuff like that – charlesreid1 Jul 27 '15 at 6:47

My Mac book stop seeing the cards, I used a can of air to clean out the reader and it works fine now.

share|improve this answer
Blowing compressed air into the SD slot on 2 of my MacBook Pros solved the problem. Thanks for that tip. I had tried everything else. – user84965 Jul 14 '14 at 0:59

Maybe some dust is stuck in the card slot. To remove, gently blow into the slot and try to insert the card again.

share|improve this answer
Could you be slightly more specific. – daniel Azuelos Feb 2 '14 at 15:54

protected by Community Jul 14 '14 at 3:13

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.