Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have a MBA and I have connected to my home network before. I went on holiday and on return, I cannot connect to Wifi anymore.

It tells me "connection time-out occurred". But my Ipod Touch (4th Gen) and Samsung Galaxy S2 can connect to the home wifi network and everyone else (I live with friends) has no issues with the wi-fi.

I already tried removing all the "Preferred networks" and tried to do an SMC reset on my Macbook Air. Nothing worked. I also went into Keychain and removed home network from there. Still not resolved

I then tried tethering my MBA to my Samsung Galaxy S2's wifi and I could connect and surf normally. (so I concluded nothing is wrong with my laptop's Airport/wifi utility)

Finally I decided to try and connect my MBA to the router via Ethernet cable, and I am able to surf and go online as normal

I updated all my software on the laptop and it is still not working. I can find my home network and click on it but when I input the password, it says "Connection Failed". I also tried setting up the network manually and inputting the password but again "Connection Failed"

I am unable to get into the router as I don't have the IP address for it. Does anyone else have a similar problem?

I have yet to try to connect to a neighbour's Wi-Fi but I will try that tonight.

share|improve this question
    
Maybe your router went on a vacation? Just kidding...Somehow your router was reset. Try resetting it to factory settings (make sure you know the log in information before you do that). –  Buscar웃 May 17 '13 at 10:39
    
Hahaha good one. I wish it did... But I don't know the log in information. It's a D-link and I tried the usual 192.168.0.1 and 192.168.1.1 but I can't get in. I'm just curious why my other devices aren't affected. But at least I know my laptop wifi isn't screwed up thank god! –  Steph M May 17 '13 at 11:49
    
there should be a label on the back of it, on the label is the log in info. usually it is as simple as user + administrator. i do not know about other devices lets focus on the problematic one. –  Buscar웃 May 17 '13 at 12:29
    
and leave the neighbor out of this, he might not be to happy hacking his router. You can actually reset the router using one of the working devices and connecting to the routers set up page, still needs a password. –  Buscar웃 May 17 '13 at 12:32
    
→ Steph: could you please add to your original question the IP address you got when you are trying to connect to your wireless network? Did you check that you are really connecting to your own wireless network and not the one of a neighbour? –  daniel Azuelos Aug 18 '13 at 20:42

2 Answers 2

  1. Try resetting any proxy settings you may have enabled (go to System Preferences > Network > Advanced > Proxy)
  2. Reset your router
  3. Attempt to connect via WPS if your router supports it
  4. Find the IP address of your router and enter it into the URL bar of your browser
share|improve this answer

I had the same error on my MAC-Book PRO and it turned out to be a MAC address issue. these are the steps I took:

  • Reset router to default settings
  • Remove network from saved network.
  • Search for network.

If this doesn't work, you might have to add the network manually.

Hope this helps.

share|improve this answer
    
if you want some points be more precise in your answer, how to reset the router, where is the factory log in saved, ho to remove the network saved, how to manually add network, I know it is SF but sometimes necessary :) –  Buscar웃 May 17 '13 at 12:34
    
can you let me know what router you are using? normally most routers have a hard reset button towards the back and that should do the trick. For removing network from saved networks: Network Preferences -> WIFI -> Advanced. You will see a list of your saved networks where you can remove. Also, the '+' button will allow you to add a network manually. –  cutoverRooster May 17 '13 at 13:37
    
Are you talking here of an error of Mac address filtering or another kind of error? –  daniel Azuelos Aug 18 '13 at 20:42
    
→ Buscar: what does SF means? I guess it couldn't be Science Fiction ;). –  daniel Azuelos Aug 18 '13 at 20:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.