Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

just some time ago i installed the OS X Server app on my mac and since this day it always appears server as the chosen directory in my terminal.

But because i dont really like the Server application i just removed it but the server in my terminal is still left. So i wonder now how i can get the default back like users/...

I am running mountain lion on my mac.

I am a real newby to both mac and usage of terminal but i need it know for some work and i just get errors every time i am trying to enter something.

share|improve this question
    
what does echo $HOME returns ? Or maybe you have something in you .profile or your .bashrc_profile that changes the Default Working Directory. –  Matthieu Riegler May 14 '13 at 23:17
2  
If the full prompt is like server:~ username$, you can change the hostname. If it's just server or something, check your ~/.bash_profile. –  Lri May 15 '13 at 9:21
    
echo home returns /Users/username –  swe19 May 15 '13 at 10:19
    
What does running pwd show? –  Mark May 15 '13 at 10:53
1  
pwd returns the same /Users/username –  swe19 May 16 '13 at 22:25
show 1 more comment

3 Answers 3

Goto your HomeFolder -> Library -> Preferences and delete the file : com.apple.terminal.plist

That should reset the settings on your Terminal

share|improve this answer
    
I can not find the terminal.plist i.e. it does not exist in my preferences libary –  swe19 May 15 '13 at 10:22
2  
From the Finder menu bar, select Go ▹ Go to Folder and copy the following line into the text box that opens: ~/Library/Preferences/com.apple.Terminal.plist –  Jash Jacob May 15 '13 at 15:01
1  
I removed it but it does not change anything. Tried to even reboot after removing and install+uninstall the server app but nothing changes. –  swe19 May 16 '13 at 22:27
    
The file is com.apple.Terminal.plist. –  Nicolas Barbulesco Nov 30 '13 at 20:15
add comment

Since you have mentioned that running pwd shows a path not mentioning server, I believe you are mistaking server for being the directory when it is actually the hostname.

OS X Server will change your hostname (by default) to server.<name>.private, so Terminal will show server:~ username$ (in Bash with the default prompt).

To change the hostname, you can use the following command:

sudo scutil --set HostName yourhostname

Replace yourhostname with your preferred hostname

share|improve this answer
add comment

I decided now to wait until mavericks would be released and make a clean new install. Hopefully everything would be working corectly afterwards. This issue gave me some problems working with terminal and because i am new to use terminal i couldn´t figure it out how to install gems. It seemed like i always was in the wrong directory because of the server to install anything.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.