Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

As the title states, I recently got a used Hard Drive from another MacBook Pro and installed it into my MacBook. The problem, is the laptop will not recognize it at all. The old hard drive just goes to a question mark. The new one takes ten minutes to get to the apple logo and another five to boot and finally lands onto the disk utility page.

Here is what I have done:

Reset PRAM SRAM....

I don't have a backup form time machine but I have tried saving OSX Mountain Lion on a USB to install it by holding the Command button. However, when installing the OSX, I get this that states:

"This disk doesn't use the GUID Partition Table scheme. Use Disk Utility to change partition scheme. Select the disk, chose the partition tab, select the Volume scheme and then click options"

However, when I go into Disk Utility, all the buttons are greyed out including the OPTIONS button and selecting the volume scheme. I also cannot erase, reformat or anything with the disk since all those buttons are greyed out as well.

I've tried so many things from google to Apple support website. The hard drive does have some data on it but I do not get the reason it is not being recognized. It doesn't show up on the left side bar by the disk. It showed up once today but then quickly disappeared.

Any help would be appreciated.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.