Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I use Font Agent Pro as my font manager of choice. I just upgraded my 2007 Mac Pro from the latest OS X 10.6 to 10.7.5 lion.

I was having a problem with Postscript Type 1 fonts not being available to Adobe or other applications, so I cleared the font cache from Terminal.

sudo atsutil databases -remove

After doing so, my Mac will not shut down - when I try to shut down the screen goes gray but the cursor can still can be moved around

I have to hit the power button to shut down manually.

Any ideas as to why this is happening?

share|improve this question
    
Can you publish your terminal script you used. –  Buscar웃 May 9 '13 at 19:37
    
Open console and locate com.apple.launchd, the open the shutdown file and look where is it stopping. –  Buscar웃 May 9 '13 at 19:41
    
Thanks, I updated the question and added the terminal command. I also opened up console, but don't really know what I'm looking for in there. –  mjr May 10 '13 at 13:25
    
there is a shutdownlog file, take look if you see anything unusual located in the console: launchd-shutdown.system.log –  Buscar웃 May 10 '13 at 16:29

3 Answers 3

The first thing and easiest step is to reset the P-RAM by holding down, immediately at startup, Command-Option-P-R . Continue this key press for three startup chimes — and release.

The second might be an SMC reset, see this Apple Support doc for details and directions for your machine.

Force Shutdown = Hold Power button down for 10 seconds.

share|improve this answer
    
Thanks for the tip. Reseting PRAM didn't seem to fix the issue in my case. –  mjr May 10 '13 at 13:25
up vote 1 down vote accepted

I've been working through the issue with Font Agent Pro Support. Evidently this is due to the Smasher Application having issues clearing the font cache if Adobe Acrobat is installed.

The solution for me was to remove Smasher. Shut down, reboot into safe mode, and restart.

That seems to have fixed the issue for now at least.

share|improve this answer

Try the full set to restart the font server

atsutil databases -removeUser
atsutil server -shutdown
atsutil server -ping
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.