Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Somehow I enabled my mac to have these "spaces" and I always have a second "desktop" - I don't know how to get rid of it.

However, either when no apps are open or if there is a fullscreen app, I do not want my external thunderbolt monitor to switch to it's new "space". I only want to switch spaces on my laptop monitor. Is there a way to disable this? I can't even find out how to disable my second desktop, period.

share|improve this question
1  
That will be addressed in OS X 10.9 Mavericks. I pretty sure it was demoed in the Keynote so I don't think I'm breaking the NDA by saying that. –  SSteve Aug 8 '13 at 21:58
add comment

1 Answer

I don't think exactly what you are asking for is possible, but this may be an acceptable solution: you can tell the application to show up in all spaces, and it will be as if your external display isn't switching spaces.

In order to do this, right click on the dock icon for your application, select "Options," and then "All Desktops"

All Desktops

Hope this helps!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.