Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I have an old Ipod Touch 8 GB which is updated till 4.2.1 and I want to use it to read my ebooks. But the problem is I cannot use IBook as it needs version 5 update and it is not possible with my Ipod. It will be so great if anyone show me the way to do this.

share|improve this question
    
Are you trying to install iOS 5 on your iPod, or are you looking to an alternative to iBooks for reading your ebooks? –  bassplayer7 May 3 '13 at 13:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.