Ask Different is a question and answer site for power users of Apple hardware and software. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MacBook Pro mid 2009 computer. Connecting my usb flash stick doesn't do anything, I tried both ports but not working. I tried connecting an iPad, the iPad charges but it doesn't open show in iTunes for syncing.

One thing to note is that Windows on VMWare recognized the devices when it is active, but not MacOSX. That means the problem is not hardware related.

share|improve this question

Have you repaired disk permissions and reset your PRAM?

Follow these instructions to repair disk permissions:

Follow these instructions to reset PRAM:

share|improve this answer
I followed your instructions to repair disk permissions and reset PRAM. Still no luck :( – user3885 Feb 25 '11 at 11:49

Go to the Apple menu and choose About This Mac. Click the More Info button. In the new window that appears, click USB under Hardware on the left. Expand the items there. Do you see your flash drive or iPod?

If not, you've probably got a hardware problem. Take it to the Apple Store if you've still got a warranty.

share|improve this answer
I can see my flash drive and iPad on the System Profiler, no problem with that. – user3885 Feb 25 '11 at 11:48

I had this happen to me this morning as I was trying to debug some iPhone code on a device. It wouldn't see my phone, a flash drive, or anything I plugged into USB. Finally, with my fingers crossed, I rebooted - when it came back up all was well.

share|improve this answer
I rebooted several times, still not working. – user3885 Feb 25 '11 at 11:48
just wanted to comment that i had the same problem and by rebooting ... the problem was gone... – Mamonu Dec 15 '13 at 18:28

You said that you have rebooted several times, but sometimes rebooting isn't enough. Did you try powering down the Mac completely, then starting it up? That is often a cure for odd problems like these when nothing else works.

share|improve this answer

There may be a preference on VMWare that it allowing the devices to go to Windows instead of Mac - I know Parallels has that. Try looking for and deactivating device preferences.

share|improve this answer

I had a similar problem. Resetting the PRAM solved it.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.