Sign up ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

My Macbook Pro (v10.6.8) is constantly automatically connecting to a neighbor's wifi - event though I've never connected to that network, and I have my own Wifi connection prioritized. The system is constantly scanning for Other Networks and lists all of my neighbors' network ahead of mine. I frequently need to reset the connection. How do I remove the list of available networks, OR disable the system from scanning the neighborhood, OR lock the Wifi connection to my in-home network? Thanks!

share|improve this question

closed as too broad by bmike Oct 16 at 17:47

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

I'm going to put a hold in this. The answer is "it depends" so we would need you to edit in your specific SSID names to be able to help you out. If someone else has a similar question - be sure to upload a screen shot of the saved networks they have in system preferences and list the names of both the desired network and the undesired network. – bmike Oct 16 at 17:48

3 Answers 3

There is no option to remove networks anywhere in the Network Preferences sheet. How is one to utilize this fix without a way to delete the networks? Not even the delete key on the keyboard is effective.

share|improve this answer

You could check your "Preferred Networks" and make sure your WiFi Access point is listed first.

To do this Open the System Preferences and select "Network" then Select the WiFi network and click the Advanced button:

enter image description here

With the WiFi tab selected from the Advanced sheet you should see a list of your preferred networks, Add, Remove, Reorder as you see fit.

share|improve this answer
The problem sounds like it's the "Ask to join new networks" setting. – Mark Apr 30 '13 at 20:11

If that network is not secured, it would try connecting to that automatically just because it is not secure. Try removing all networks that do not require a password to join, and that should fix it.

Using sdmeyers method is the correct way to removing networks from your preferences

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.