Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

When I look in Activity Monitor in Mac OS X 10.8.3 on a Macbook Pro 15" Retina while running Chrome (Build 26.0.1410.64) in a Windows 8 Pro VM hosted in Parallels 8 (Build 8.0.18483) I see that the "Parallels VM" process is constantly showing 40-50% CPU usage, even when the VM is idle. At the same time the Win 8 Task Manager only shows 2-3% CPU usage for all running processes. Closing Chrome in the VM immediately drops the processor usage for "Parallels VM" on the Mac side down to 7-8% (Windows 8 Task Manager still shows only 2-3% CPU usage by all processes).

I can see this problem when Chrome is the only application running in the Win 8 VM.

This problem only happens when a web page is open in Chrome. Plug-in settings for Chrome are set to 'Click to play'. I am not clicking to play any plug-ins when I load a web page.

Some information about my setup:

My Parallels VM is set to use two CPU cores. This would explain why (when Chrome isn't running) I'm seeing about double the CPU usage for the "Parallels VM" Mac process as I see being used by all process when viewing Task Manager on the Win 8 side, since the Mac's activity monitor reports processor usage by all cores and combines those values for the display CPU usage value.

Parallels is running in full-screen (non-Coherence) mode.

Windows 8 Pro has all current updates installed.

Chrome 26 is a base install with default settings and no extensions are installed other than the default 'Google Docs' extension, which is disabled.

Does anyone else have this issue and, if so, have you found a fix?

share|improve this question
    
Do you NEEED to run chrome in W8? VM Ware Fusion (and probably parallels) has a setting to forward links to your mac's native default web browser. –  XAleXOwnZX Apr 28 '13 at 1:44
    
Yes, the main reason being that I using Visual Studio's built in web server, which creates a loopback interface which is not accessible from outside the VM (not without a lot of trouble at least). Also, I like to keep everything on the Windows side when I'm doing Windows development. And to clarify, Visual Studio is not running when I see this problem. Using Win Firefox is an alternative, but I prefer Chrome's developer tools for certain situations. –  recklesscoder Apr 28 '13 at 1:52
    
Regarding your query if others have this issue: I do not have the same issue. I have basically the same setup as you (but non-Retina, and Parallels is allowed to use 7/8 CPUs). Chrome jacks the CPUs way high briefly and then puts it back to ~55% (normal idle, no other programs open). Have you noticed performance issues as a result of Chrome running on your VM? –  bassplayer7 Apr 28 '13 at 2:31
    
The performance issues I've noticed are significantly decreased battery-life (due to the constantly high CPU usage) and a pretty hot Mac. –  recklesscoder Apr 28 '13 at 2:36
    
@bassplayer7.... ~55% is NORMAL???? Are you kidding me? It sounds like you have accepted poor performance and don't care. Sorry if it sounds harsh, but that is completely unacceptable to me! –  user53504 Jul 18 '13 at 15:53

1 Answer 1

up vote 1 down vote accepted

I had a similar problem in Windows 7 guest OS under Parallels 8. This fixed it:

In Chrome, go to chrome://flags and set 'GPU compositing on all pages' to "Disabled". Restart Chrome

There is a bug report related to this with more details: http://code.google.com/p/chromium/issues/detail?id=172521

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.