Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've been using a Mac account for years. Just checked on my iPad that only posts made on iCloud the last 30 days are on Calendar. None of the older ones appear. I've already turn off and on on settings.

Thanks a lot.

Miguel.

share|improve this question
add comment

1 Answer

By default, the iOS calendar only syncs events within a specific timeframe, but you can adjust that within the settings.

Open the Mail, Contacts, Calendars section in Settings, and scroll down to the Sync option under Calendars:

Calendar settings

Tap that, and you'll get the option to choose how far back you want events to appear, or if you want all events to appear:

sync options

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.