Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sometimes, I don't get access to the Display Audio that my Thunderbolt Apple Display provides when I dock to the machine with my MacBook Pro. The clunky way to solve this, is a reboot. I've tried using the Apple Preferences (Sound), but that fails to provide the option, unless I reboot. Here is what my system_profiler shows as available Sound/Devices after the reboot (and when the Apple Preferences does give me the option to select the bigger Thunderbolt display):


    Built-in Input:

      Input Channels: 2
      Manufacturer: Apple Inc.
      Current SampleRate: 44100
      Transport: Built-in

    Built-in Output:

      Default System Output Device: Yes
      Manufacturer: Apple Inc.
      Output Channels: 2
      Current SampleRate: 44100
      Transport: Built-in

    Display Audio:

      Default Input Device: Yes
      Default Output Device: Yes
      Input Channels: 1
      Manufacturer: Apple Inc.
      Output Channels: 2
      Current SampleRate: 44100
      Transport: USB

Any ideas how to 'wake-up' the Thunderbolt connection to recognize the third item (Display Audio) without resorting to a reboot? Ideally, that would at least activate it as an option in the Apple Preferences menu.

Here's a picture of the Preferences: Apple Preferences Dialog

share|improve this question
I have a similar issue on occasion when connecting a DisplayPort monitor. I just open the sound preference control panel and select the display out (or worst case, select an AirPlay output to cause it to refresh the list of devices). Are you not even seeing Display as an option when you connect it? – bmike Apr 24 '13 at 19:45
I just added the picture. When it is 'fully' connected, the MacBook Pro & Thunderbolt display give two options for the 'Output'. As you can see -- when things are squirrelly, I only get the internal, tinny, MBP speakers. – Rolnik Apr 24 '13 at 20:41
Ouch. I'd file a bug and hope it's something that is fixable in software rather than a hardware problem with your Mac or your display. – bmike Apr 24 '13 at 20:50

Since the USB connection to the speakers is tunneled over the Thunderbolt cable to the Mac, you might need to hot plug that (disconnect and reconnect).

I would be curious if logging out of your user and logging back in restores the sound destination. If so, it's likely a software issue on Apple's OS X side. If not, then it's likely a firmware issue or hardware issue on the display side.

Sorry I can't be more specific, but that's how I'd try and corner the actual root cause/culprit.

share|improve this answer

I've experienced this annoyance too. Rebooting can be very inconvenient when I have a lot of work open. Unplug/plugging the monitor doesn't seem to help. After reading the answer above, I started to log out, canceled it and for some reason the display audio option was restored. Woohoo! I'll repeat same procedure next time and see if this was just luck.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.