Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

About a week ago, my OSX machine stopped connecting to any WiFi networks automatically. If I open the WiFi menu from the top bar and select the desired network, it connects OK. Also, if I enable "Ask to join new networks" from the Network preferences, it shows the "No preferred networks found" dialog, even though the network is both in the list shown in that window AND in the preferred networks list in Network preferences -> WiFi -> Advanced...`.

The issue is repeatable both in my work and home networks. As far as I know, I've done no configuration changes or updates or such since the 10.8.3 update.

UPDATE: This may be hackintosh-related, since I get an error message from the bootloader saying Unable to handle key preferred-networks. I'm not sure what this site's stance on hackintoshes is so I posted this on the bootloader's forum as well. UPDATE 2: Not an issue of the bootloader.

Edit: In reference to Buscar's comment, this is my view of the network preferences:

enter image description here

share|improve this question
    
If you check the Automatically Join this network it does not work ? –  Buscar 웃 Apr 24 '13 at 7:17
    
@Buscar웃 Where can I find that option? –  onik Apr 24 '13 at 7:37
    
Network, right under the network name above the ask to join –  Buscar 웃 Apr 24 '13 at 7:43
    
@Buscar웃 There is no such option, see updated question. –  onik Apr 24 '13 at 7:48
    
in os x 10.8.3 MBA –  Buscar 웃 Apr 24 '13 at 7:49
show 4 more comments

4 Answers

up vote 4 down vote accepted

Reading this question reminded me that I had dealt with the same problem with my Mac awhile ago.

I fixed it by writing a shell script which was automatically called via launchd whenever /Library/Preferences/SystemConfiguration/ changes.

You'll have to configure a few things, mainly create a list of known SSIDs and passwords for the networks that you join.

You can find it here: https://github.com/tjluoma/airport-autojoin

share|improve this answer
    
Thanks a lot, this worked great! –  onik Apr 25 '13 at 18:09
    
Awesome! I'm glad to hear it was useful to someone else, especially after I re-wrote it :-) If you pull it apart and try some of the commands on the command-line, you might get a better error message than what System Preferences shows you. –  TJ Luoma Apr 26 '13 at 18:20
add comment

Sometimes network locations get messed up, but you can start fresh: go into the Location menu and create a new network location. Click on Apply, and check again and the WiFi situation improves.

share|improve this answer
    
I tried this but it doesn't change the situation. –  onik Apr 24 '13 at 8:15
add comment

The option Automatically Join This network will only appear once you are connected.

So connect first to your network, than check the auto join.

enter image description here

If you do not see the "Automatically Join this network" do following:

Go to System Preferences/Network- Advanced

Click (+) to add your network (Choose it)

and drag it to the top (optional)

enter image description here enter image description here

check "Remember networks" and OK

Back in the Airport Main screen Turn wifi OFF to disconnect from current.

then turn wifi back on

Select the network you just added in the preferred networks.

After successfully connecting the Auto join will appear if you have followed the steps.

share|improve this answer
    
As you can see from the screenshot, I'm already connected, but the option doesn't show up. –  onik Apr 24 '13 at 8:33
    
I tried your suggestion, still no such checkbox... –  onik Apr 24 '13 at 9:09
    
Still no change... –  onik Apr 24 '13 at 9:48
    
@onik check my last effort –  Buscar 웃 Apr 24 '13 at 11:15
    
I've tried this too, still can't make it appear. –  onik Apr 24 '13 at 11:25
show 3 more comments
  1. Click the Advanced button on the Network Preference page.
  2. On the next page, select the checkbox on the "Remember networks this computer has join".
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.