Take the 2-minute tour ×
Ask Different is a question and answer site for power users of Apple hardware and software. It's 100% free, no registration required.

I've setup an Exchange account to point to my work address and it works pretty well. The only annoyance is that if I receive an email that has several recipients, pressing Reply All, also includes me on the To or CC list.

When I do the same operation in Outlook, I am not included in the To/CC list.

How can I get the iPhone to stop including me on the Reply All?

share|improve this question
    
what do you mean by "point to"? if you mean angry@anywhere point to hacker@elsewhere and this second one is your iphone's, then there's your issue. –  Cawas Feb 23 '11 at 14:11
    
@Cawas No, it just means that i have an Exchange account at work, and my iPhone is connected to it. –  AngryHacker Feb 24 '11 at 17:55

3 Answers 3

up vote 3 down vote accepted

A coworker pointed out an inconsistency with my email account and that led to the resolution of the issue.

On our corporate server, there is a main email address and you could also make any number of aliases. So for instance, my email address is frankrizzo@mycompany.com. But if you send me an email to frank.rizzo@mycompany.com or frank+rizzo@mycompany.com, it will reach me as well.

In the iPhone, I entered my account as frank.rizzo@mycompany.com (with the dot). However, people kept sending emails to my main account - frankrizzo@mycompany.com - without the dot. The iPhone saw the one without the dot as not mine and thus was including it on the Reply All screen.

share|improve this answer
    
I tried changing my email address to the same as my account however it still sends to me as well. –  user81289 Jun 9 at 21:19

I think this only happened on older versions of the software. I just tested it on iOS 4.2.1 and it didn't happen to me but I remember it used to happen. I don't know which version fixed it but you could update to the latest version of iOS and that should fix it.

share|improve this answer
    
I got iOS 4.2.1 and it still happens. Could it be a setting somewhere? –  AngryHacker Feb 22 '11 at 23:52
    
@Angry it could be some legacy setting that came along with updates. Usually the recommendation is to start a fresh iOS installation, wiping everything. But if iOS really fixed it, I bet there's some way around it. –  Cawas Feb 25 '11 at 17:49

I had the same issue and discovered the email address in my iPhone Mail app account was different from my actual email address.

Therefore Mail.app did not recognize my address in emails sent to me as my own. I changed the email in account on Mail app and it works now

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.